summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:34:47 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:14 -0500
commite0060729b5dfa678bd686ad20435485a73f3d4d0 (patch)
tree4a911f4f3183d7d29ce1deef44fad12d9dba0996 /gnu
parent13ab4abe98f1a88256d4ecd9b3ee3cb026515f4e (diff)
gnu: go-github-com-sourcegraph-jsonrpc2: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-sourcegraph-jsonrpc2): Move from here... * gnu/packages/golang-web.scm: ...to here. * gnu/packages/databases.scm: Add (gnu packages golang-web) module. Change-Id: Idda2e18ae5d3e19f72265bdd017eadddc25bcad9
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/databases.scm1
-rw-r--r--gnu/packages/golang-web.scm26
-rw-r--r--gnu/packages/golang.scm26
3 files changed, 27 insertions, 26 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 1ca534aa00..564927c2a7 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -108,6 +108,7 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
#:use-module (gnu packages golang-check)
+ #:use-module (gnu packages golang-web)
#:use-module (gnu packages gperf)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 0ca70cec38..f9e7039707 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -208,6 +208,32 @@ protocol.")
to jQuery to the Go language.")
(license license:bsd-3)))
+(define-public go-github-com-sourcegraph-jsonrpc2
+ (package
+ (name "go-github-com-sourcegraph-jsonrpc2")
+ (version "0.1.0")
+ (home-page "https://github.com/sourcegraph/jsonrpc2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dk0w32k96vxrwnmm24wqx337dn8ylch65qwrbc3wh7whw2xx71q"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/sourcegraph/jsonrpc2"))
+ (propagated-inputs
+ (list go-github-com-daviddengcn-go-colortext
+ go-github-com-gorilla-websocket
+ go-github-com-motemen-go-colorine))
+ (synopsis "Provides a client and server implementation of JSON-RPC 2.0")
+ (description
+ "Package jsonrpc2 provides a Go implementation of JSON-RPC 2.0.")
+ (license license:expat)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9fe55bc551..f51d8fd455 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12909,32 +12909,6 @@ to use in various HTML contexts and with various DOM APIs.")
using shell-style rules for quoting and commenting.")
(license license:asl2.0)))
-(define-public go-github-com-sourcegraph-jsonrpc2
- (package
- (name "go-github-com-sourcegraph-jsonrpc2")
- (version "0.1.0")
- (home-page "https://github.com/sourcegraph/jsonrpc2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1dk0w32k96vxrwnmm24wqx337dn8ylch65qwrbc3wh7whw2xx71q"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/sourcegraph/jsonrpc2"))
- (propagated-inputs
- (list
- go-github-com-daviddengcn-go-colortext
- go-github-com-motemen-go-colorine
- go-github-com-gorilla-websocket))
- (synopsis "Provides a client and server implementation of JSON-RPC 2.0")
- (description
- "Package jsonrpc2 provides a Go implementation of JSON-RPC 2.0.")
- (license license:expat)))
-
(define-public go-github-com-disintegration-imaging
(package
(name "go-github-com-disintegration-imaging")