summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-20 21:32:14 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:11:00 -0400
commitf7b87f777552dd515183334f11f8fcd518c8fa15 (patch)
treefe83a4ff324d8128d587e283edd3122623e47d22 /gnu
parent968137837ec9e16cfe1e8902929af87d518b520c (diff)
gnu: NSS: Update to 3.85.
* gnu/packages/nss.scm (nss): Update to 3.85. * gnu/packages/certs.scm (nss-certs): Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/certs.scm4
-rw-r--r--gnu/packages/nss.scm6
2 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index b8dfe96e6d..122882980b 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -131,7 +131,7 @@ that was originally contributed to Debian.")
;; XXX We used to refer to the nss package here, but that eventually caused
;; module cycles. The below is a quick copy-paste job that must be kept in
;; sync manually. Surely there's a better way…?
- (version "3.81")
+ (version "3.85")
(source (origin
(method url-fetch)
(uri (let ((version-with-underscores
@@ -142,7 +142,7 @@ that was originally contributed to Debian.")
"nss-" version ".tar.gz")))
(sha256
(base32
- "19ncvhz45dhr0nmymwkxspq9l44gaafkspxiwxbqs1hpnqxmzgx8"))
+ "15yj2gddlp68wj1k9q4q70vs6r7zx5qkbavcppmls5di212xdndg"))
;; Create nss.pc and nss-config.
(patches (search-patches "nss-3.56-pkgconfig.patch"
"nss-getcwd-nonnull.patch"
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 6e4583115c..056fdba450 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -126,7 +126,7 @@ in the Mozilla clients.")
(replacement nss/fixed)
;; Also update and test the nss-certs package, which duplicates version and
;; source to avoid a top-level variable reference & module cycle.
- (version "3.81")
+ (version "3.85")
(source (origin
(method url-fetch)
(uri (let ((version-with-underscores
@@ -137,7 +137,7 @@ in the Mozilla clients.")
"nss-" version ".tar.gz")))
(sha256
(base32
- "19ncvhz45dhr0nmymwkxspq9l44gaafkspxiwxbqs1hpnqxmzgx8"))
+ "15yj2gddlp68wj1k9q4q70vs6r7zx5qkbavcppmls5di212xdndg"))
;; Create nss.pc and nss-config.
(patches (search-patches "nss-3.56-pkgconfig.patch"
"nss-getcwd-nonnull.patch"
@@ -200,7 +200,7 @@ in the Mozilla clients.")
;; leading to test failures:
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To
;; work around that, set the time to roughly the release date.
- (invoke "faketime" "2022-06-01" "./nss/tests/all.sh"))
+ (invoke "faketime" "2022-11-01" "./nss/tests/all.sh"))
(format #t "test suite not run~%"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)