summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2023-02-13 11:17:56 +0000
committerEfraim Flashner <efraim@flashner.co.il>2023-02-14 17:04:41 +0200
commit25df704601b73fbdc083d57b68628960969f5cbe (patch)
tree94833eac17e7813c5a675e6333bd8e2cdf6cd381 /gnu
parentc4fca4340343dc1a00c873074185e1902da43477 (diff)
gnu: Add rust-protobuf-codegen-2.
* gnu/packages/crates-io.scm (rust-protobuf-codegen-2): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e45263041e..44fe03206b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -43175,6 +43175,30 @@ language.")
"This package provides a library to read and write protocol buffer's data.")
(license license:expat)))
+;; It's recommended that rust-protobuf, rust-protobuf-codegen
+;; and rust-probuf-codegen-pure be the same version
+(define-public rust-protobuf-codegen-2
+ (package
+ (name "rust-protobuf-codegen")
+ (version "2.14.0")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "protobuf-codegen" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "031bx325lsgcx7wc76vc2cqph6q0b34jgc8nz0g2rkwcfnx3n4fy"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-protobuf" ,rust-protobuf-2))))
+ (home-page "https://github.com/stepancheg/rust-protobuf/")
+ (synopsis "Code generator for rust-protobuf")
+ (description
+ "This package provides a code generator for rust-protobuf. It includes a
+library to invoke programmatically (e.g. from @code{build.rs}) and
+@code{protoc-gen-rust} binary.")
+ (license license:expat)))
+
(define-public rust-psl-2
(package
(name "rust-psl")