summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-20 21:41:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-20 21:41:40 +0200
commit2f646a3fea847c713d36c73719de218f7c4c2a8e (patch)
treea65458999f57137009a6766ab7dee523cc900803 /gnu
parent893f8d1c50f3d276bf9acb1278acb813489f1476 (diff)
gnu: Add rust-base64-0.22.
* gnu/packages/crates-io.scm (rust-base64-0.22): New variable. (rust-base64-0.21): Inherit from above. Change-Id: I55e4ddc1c2d1bd127c8fdbbeeea2ee0b0e47a1d7
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm36
1 files changed, 29 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 46e211d56c..20608b8353 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -6630,8 +6630,36 @@ RFC4648 Base32 or in Crockford Base32.")
c6e7d37. However, this package works only up to 128 bytes.")
(license license:expat)))
+(define-public rust-base64-0.22
+ (package
+ (name "rust-base64")
+ (version "0.22.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "base64" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1imqzgh7bxcikp5vx3shqvw9j09g9ly0xr0jma0q66i52r7jbcvj"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-development-inputs
+ (("rust-clap" ,rust-clap-3)
+ ("rust-criterion" ,rust-criterion-0.4)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-rstest" ,rust-rstest-0.13)
+ ("rust-rstest-reuse" ,rust-rstest-reuse-0.6)
+ ("rust-strum" ,rust-strum-0.25))))
+ (home-page "https://github.com/marshallpierce/rust-base64")
+ (synopsis "Encodes and decodes base64 as bytes or utf8")
+ (description
+ "This package encodes and decodes base64 as bytes or utf8.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-base64-0.21
(package
+ (inherit rust-base64-0.22)
(name "rust-base64")
(version "0.21.7")
(source (origin
@@ -6641,7 +6669,6 @@ c6e7d37. However, this package works only up to 128 bytes.")
(sha256
(base32
"0rw52yvsk75kar9wgqfwgb414kvil1gn7mqkrhn9zf1537mpsacx"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-development-inputs
(("rust-clap" ,rust-clap-3)
@@ -6650,12 +6677,7 @@ c6e7d37. However, this package works only up to 128 bytes.")
("rust-rand" ,rust-rand-0.8)
("rust-rstest" ,rust-rstest-0.13)
("rust-rstest-reuse" ,rust-rstest-reuse-0.6)
- ("rust-strum" ,rust-strum-0.25))))
- (home-page "https://github.com/marshallpierce/rust-base64")
- (synopsis "Encodes and decodes base64 as bytes or utf8")
- (description
- "This package encodes and decodes base64 as bytes or utf8.")
- (license (list license:expat license:asl2.0))))
+ ("rust-strum" ,rust-strum-0.25))))))
(define-public rust-base64-0.20
(package