summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-24 16:51:19 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-30 14:41:48 +0100
commit2f9e0b68e1d4098fe8259ea5113c160b7008c5e2 (patch)
tree9be19b8a1946598bf14423fa7a91e2e6e8ff4f2c /gnu
parentfe1ddad54ac430ddf684c5d5fff9dffb9ec7bcb3 (diff)
gnu: Add ruby-ci-reporter.
* gnu/packages/ruby.scm (ruby-ci-reporter): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1aa03972d1..a01eefc2ed 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -544,6 +544,33 @@ line of code.")
;; of the Expat license.
(license license:bsd-3)))
+(define-public ruby-ci-reporter
+ (package
+ (name "ruby-ci-reporter")
+ (version "2.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "ci_reporter" version))
+ (sha256
+ (base32
+ "17fm20jmw3ajdryhkkxpjahcfx7bgswqzxrskivlkns2718ayyyg"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:test-target "rspec"))
+ (propagated-inputs
+ `(("ruby-builder" ,ruby-builder)))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)))
+ (synopsis "Generate XML reports of runs test")
+ (description
+ "@code{CI::Reporter} is an add-on to Ruby testing frameworks that allows
+you to generate XML reports of your test runs. The resulting files can be
+read by a continuous integration system that understands Ant's JUnit report
+format.")
+ (home-page "https://github.com/nicksieger/ci_reporter")
+ (license license:expat)))
+
(define-public ruby-orderedhash
(package
(name "ruby-orderedhash")