summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorIlya Chernyshov <ichernyshovvv@gmail.com>2024-06-03 18:47:27 +0700
committerAndrew Tropin <andrew@trop.in>2024-06-05 13:15:49 +0400
commit425cf1fbe2fff25bda1b5eb948ce01170d23ab6a (patch)
tree47dc2724bde7489d8d844b6d189be24e3d0e806c /gnu
parent6e1bd62d55a088deeef5534e8c7ad63420d36bb3 (diff)
gnu: Add emacs-enlight.
From a411c84f26718c81fd2a762ca310fb0bfd6f60f6 Mon Sep 17 00:00:00 2001 Message-ID: <a411c84f26718c81fd2a762ca310fb0bfd6f60f6.1717415177.git.ichernyshovvv@gmail.com> From: Ilya Chernyshov <ichernyshovvv@gmail.com> Date: Mon, 3 Jun 2024 10:53:18 +0000 Subject: [PATCH] gnu: Add emacs-enlight. * gnu/packages/emacs-xyz.scm (emacs-enlight): New variable. Change-Id: Ifb1d519d1bd89dec7414ee0fd5858a26e49dc1ca Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index efe28506ec..bef0afc99f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -138,6 +138,7 @@
;;; Copyright © 2023 Ian Eure <ian@retrospec.tv>
;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
;;; Copyright © 2024 dan <i@dan.games>
+;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26648,6 +26649,26 @@ Emacs minor mode to escape sequences in code.")
sections for bookmarks, Projectile projects, Org Agenda and more.")
(license license:gpl3+)))
+(define-public emacs-enlight
+ (package
+ (name "emacs-enlight")
+ (version "0.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ichernyshovvv/enlight")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0crccz28f54xc0202gdbnpkn7kfsxf66p2m2grs6wnwyjxrmpnsq"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-compat))
+ (home-page "https://github.com/ichernyshovvv/enlight")
+ (synopsis "Highly customizable startup screen for Emacs")
+ (description "Lightweight yet very flexible startup screen for Emacs.")
+ (license license:gpl3+)))
+
(define-public emacs-slime-company
(package
(name "emacs-slime-company")