summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-14 16:55:02 -0400
committerLeo Famulari <leo@famulari.name>2016-10-14 16:58:09 -0400
commit470613f962dc93999c3505a2e84d3ab8016ffd8e (patch)
tree7179783e27d72379a6ed5fdb874e4a0b3b4bc8ae /gnu
parent90dcd496633fcbbfc27553118605f401f39a903e (diff)
gnu: python-cryptography: Ignore spurious test failure.
* gnu/packages/python.scm (python-cryptography, python2-cryptography)[arguments]: Add 'disable-failing-test' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f1bdee28b8..1b35bf0807 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6215,6 +6215,20 @@ responses, rather than doing any computation.")
(base32
"1a85l548w5vvq3yhz0az7ajg2ijixzp6gagapw6wgrqvq28ghgs2"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'disable-failing-test
+ (lambda _
+ ;; This test is known to fail with OpenSSL >= 1.0.2i and older
+ ;; versions of python-cryptography:
+ ;; https://github.com/pyca/cryptography/issues/3196
+ ;; TODO: Try re-enabling the test when upgrading
+ ;; python-cryptography.
+ (substitute* "tests/hazmat/backends/test_openssl.py"
+ (("def test_numeric_string_x509_name_entry")
+ "@pytest.mark.xfail\n def test_numeric_string_x509_name_entry"))
+ #t)))))
(inputs
`(("openssl" ,openssl)))
(propagated-inputs