summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-25 17:56:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-25 19:10:18 +0200
commit8664c6230e185332167a63d3a160c3eec83fd55c (patch)
treeec2677cc550c4cc68e7b02543317d1285b1933ad /gnu
parent8c5ba69d6e9e4b1b9d6b5e9cd28859b19e8e180c (diff)
gnu: Add wfa2-lib.
* gnu/packages/bioinformatics.scm (wfa2-lib): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index dfe82efe22..c981d69a8e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -17145,6 +17145,29 @@ which would benefit from directly reading subsequences from FASTA files. The
library automatically handles index file generation and use.")
(license (list license:expat license:gpl2))))
+(define-public wfa2-lib
+ (package
+ (name "wfa2-lib")
+ (version "2.3.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/smarco/WFA2-lib")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "110s1s79z8ndjs4qdgmrj708iiaqyagia3gi2fxak101lg263diw"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ (list pkg-config))
+ (home-page "https://github.com/smarco/WFA2-lib")
+ (synopsis "Wavefront alignment algorithm library")
+ (description "The wavefront alignment (WFA) algorithm is an exact
+gap-affine algorithm that takes advantage of homologous regions between the
+sequences to accelerate the alignment process.")
+ (license license:expat)))
+
(define-public vcflib
(package
(name "vcflib")