summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-05-28 23:27:36 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-05-29 21:15:39 -0400
commit9e5d9f4a2dce590e306ff99770cf51e55b5a8fab (patch)
tree7b8c34638ed99e245fd26e274982ae8dec84fb60 /gnu
parentdef8733e035dd08300df3894b38f828dd9b6cc2e (diff)
gnu: ffmpeg-jami: Enable pipewire support.
* gnu/packages/video.scm (ffmpeg-jami) [arguments]: Update configure flags. [inputs]: Add pipewire. * gnu/packages/patches/ffmpeg-jami-pipewiregrab-source-filter.patch: Fix includes. Change-Id: Ife3bf532496bc06144c1cbbcea50e406a58ecc7a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/ffmpeg-jami-pipewiregrab-source-filter.patch4
-rw-r--r--gnu/packages/video.scm9
2 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/patches/ffmpeg-jami-pipewiregrab-source-filter.patch b/gnu/packages/patches/ffmpeg-jami-pipewiregrab-source-filter.patch
index f2da4f478f..53b6ad7da2 100644
--- a/gnu/packages/patches/ffmpeg-jami-pipewiregrab-source-filter.patch
+++ b/gnu/packages/patches/ffmpeg-jami-pipewiregrab-source-filter.patch
@@ -75,7 +75,7 @@ new file mode 100644
index 0000000000..ff9c3468ab
--- /dev/null
+++ b/libavfilter/vsrc_pipewiregrab.c
-@@ -0,0 +1,1373 @@
+@@ -0,0 +1,1375 @@
+/*
+ * PipeWire input grabber (ScreenCast)
+ * Copyright (C) 2024 Savoir-faire Linux, Inc.
@@ -117,6 +117,8 @@ index 0000000000..ff9c3468ab
+#include <sys/mman.h>
+#include <sys/queue.h>
+
++#include "libavfilter/formats.h"
++#include "libavfilter/video.h"
+#include "libavutil/internal.h"
+#include "libavutil/mathematics.h"
+#include "libavutil/opt.h"
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2e7ba6d10e..0960410498 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2050,6 +2050,11 @@ audio/video codec library.")
"--disable-programs"
"--disable-postproc"
+ "--enable-libpipewire"
+ "--enable-filter=pipewiregrab"
+ "--enable-indev=lavfi"
+ "--enable-decoder=wrapped_avframe"
+
"--disable-protocols"
"--enable-protocol=crypto"
"--enable-protocol=file"
@@ -2257,7 +2262,9 @@ audio/video codec library.")
"--enable-encoder=vp8_vaapi"
"--enable-encoder=mjpeg_vaapi"
"--enable-encoder=hevc_vaapi")
- '())))))))
+ '())))))
+ (inputs (modify-inputs (package-inputs ffmpeg)
+ (append pipewire)))))
(define-public ffmpegthumbnailer
(package