summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-05-27 13:11:13 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-05-29 21:15:39 -0400
commit9ed847f8289b4a6f1855c0aa0cba9c94e09a9dc8 (patch)
tree8cc02b80f5a065225943a7e45b84b106807f7309 /gnu
parent9e5d9f4a2dce590e306ff99770cf51e55b5a8fab (diff)
gnu: jami: Update to 20240524.0.
* gnu/packages/jami.scm (libjami): Update to 20240524.0. [source]: Remove stale integration tests patch. [arguments] <#tests?> Set to #f, disabling tests. [inputs]: Replace libgit2-1.6 with libgit2-1.8. [phases] <move-jamid>: Update comment. * gnu/packages/patches/jami-disable-integration-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it. (jami): Update to 20240524.0. Series-postfix: telephony-team Change-Id: I6e46ca936951ff41e8f322eed2b5a663e1e3d197
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/jami.scm23
-rw-r--r--gnu/packages/patches/jami-disable-integration-tests.patch113
3 files changed, 13 insertions, 124 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 7e9e1ebcf0..e9e0f184f4 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1505,7 +1505,6 @@ dist_patch_DATA = \
%D%/packages/patches/isl-0.11.1-aarch64-support.patch \
%D%/packages/patches/isync-openssl3-fix.patch \
%D%/packages/patches/itk-snap-alt-glibc-compat.patch \
- %D%/packages/patches/jami-disable-integration-tests.patch \
%D%/packages/patches/jami-libjami-headers-search.patch \
%D%/packages/patches/jami-qwindowkit.patch \
%D%/packages/patches/jami-skip-tests-requiring-internet.patch \
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index 81c9a3d3c2..cb5995cc14 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -78,8 +78,8 @@
;;; When updating Jami, make sure that the patches used for ffmpeg-jami are up
;;; to date with those listed in
;;; <https://review.jami.net/plugins/gitiles/jami-daemon/+/refs/heads/master/contrib/src/ffmpeg/rules.mak>.
-(define %jami-nightly-version "20240325.0")
-(define %jami-daemon-commit "32f39e65483cb22729eb922d72434013b337f2c9")
+(define %jami-nightly-version "20240524.0")
+(define %jami-daemon-commit "fd2f2815448ce4072dcbc3995950788573d63f3b")
(define-public libjami
(package
@@ -93,14 +93,18 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0kha2v46l5hmycklhyxrs2qybm640nbrk98z1xvicjxyq6bfszh4"))
+ "1bw0laj93w4pvlxsr5abz59805ypbmg21z5393yzm82j4d35cfyr"))
(patches (search-patches
- "libjami-ac-config-files.patch"
- "jami-disable-integration-tests.patch"))))
+ "libjami-ac-config-files.patch"))))
(outputs '("out" "bin" "debug")) ;"bin' contains jamid
(build-system gnu-build-system)
(arguments
(list
+ ;; XXX: The test suites reportedly takes 2 h 30 to run by upstream's CI.
+ ;; Many tests also fail, within and without the containerized
+ ;; environment. Some issues have recently been fixed, so try again in
+ ;; the next release.
+ #:tests? #f
;; The agent links the daemon binary with libguile, which enables the
;; execution of test plans described in Scheme. It may be useful in
;; user scripts too, until more general purpose Scheme bindings are made
@@ -122,9 +126,8 @@
(find-files (string-append #$output "/lib")
"\\.a$"))))
(add-after 'install 'move-jamid
- ;; This nearly halves the size of the main output (from 1566.2 MiB
- ;; to 833.6 MiB), due to not depending on dbus-c++ and its large
- ;; dependencies.
+ ;; This reduces the size of the main output, due to not depending
+ ;; on sdbus-c++.
(lambda* (#:key outputs #:allow-other-keys)
(let ((libexec (string-append #$output:bin "/libexec"))
(share (string-append #$output:bin "/share")))
@@ -144,7 +147,7 @@
jack-1
jsoncpp
libarchive
- libgit2-1.6
+ libgit2-1.8
libnatpmp
libsecp256k1
libupnp
@@ -227,7 +230,7 @@ QSortFilterProxyModel conveniently exposed for QML.")
(file-name (git-file-name name version))
(sha256
(base32
- "08lv8azjd47n56i25d9ax248xmidixpsnwh5kc4qjxib7985bdhs"))
+ "1wqi50n80khyngj48brc8wg3m6jq471h9gm62yxpj4f8z5j81ncd"))
(patches (search-patches
"jami-libjami-headers-search.patch"
"jami-qwindowkit.patch"
diff --git a/gnu/packages/patches/jami-disable-integration-tests.patch b/gnu/packages/patches/jami-disable-integration-tests.patch
deleted file mode 100644
index 18f13800ac..0000000000
--- a/gnu/packages/patches/jami-disable-integration-tests.patch
+++ /dev/null
@@ -1,113 +0,0 @@
-This issue is tracked at https://git.jami.net/savoirfairelinux/jami-daemon/-/issues/824.
-
-From 3fd7acc6e5a8c316c366827956d7c06affdc9685 Mon Sep 17 00:00:00 2001
-From: Olivier Dion <olivier.dion@savoirfairelinux.com>
-Date: Fri, 7 Oct 2022 15:20:37 -0400
-Subject: [PATCH] test/unitTest: Seperate pure tests from integration tests
-
-So we can now do `make check` in a reproducible way.
-
-To enable integration tests `./configure --enable-integration-tests`.
-
-Change-Id: Iaa68c77abade9fe78bae881abc25e034bcb6a067
----
-With file names adjusted for the source tarball.
-
- configure.ac | 5 ++++
- test/unitTest/Makefile.am | 52 +++++++++++++++++++++------------------
- 2 files changed, 33 insertions(+), 24 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 27215d044..aaeef1c1b 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -40,6 +40,11 @@ AS_IF([test "x$enable_debug" = "xyes"],
- [DAEMONCFLAGS+=" -DNDEBUG=1 -O3"
- DAEMONCXXFLAGS+=" -DNDEBUG=1 -O3 -Wno-deprecated"])
-
-+AC_ARG_ENABLE([enable_integration_tests],
-+ AS_HELP_STRING([--enable-integration-tests],
-+ [Also run integration tests with check target]))
-+AM_CONDITIONAL([ENABLE_INTEGRATION_TESTS], [test "x$enable_integration_tests" = "xyes"])
-+
- AC_ARG_ENABLE([fuzzing],
- AS_HELP_STRING([--enable-fuzzing],
- [Build fuzzing tools]))
-diff --git a/test/unitTest/Makefile.am b/test/unitTest/Makefile.am
-index f2b0fd994..ab232ddb7 100644
---- a/test/unitTest/Makefile.am
-+++ b/test/unitTest/Makefile.am
-@@ -13,30 +13,6 @@ check_PROGRAMS =
-
- ####### Unit Test ########
-
--#
--# account_factory
--#
--check_PROGRAMS += ut_account_factory
--ut_account_factory_SOURCES = account_factory/testAccount_factory.cpp common.cpp
--
--#
--# account_archive
--#
--check_PROGRAMS += ut_account_archive
--ut_account_archive_SOURCES = account_archive/account_archive.cpp common.cpp
--
--#
--# migration
--#
--check_PROGRAMS += ut_migration
--ut_migration_SOURCES = account_archive/migration.cpp common.cpp
--
--#
--# certstore
--#
--check_PROGRAMS += ut_certstore
--ut_certstore_SOURCES = certstore.cpp common.cpp
--
- #
- # scheduler
- #
-@@ -127,6 +103,32 @@ ut_video_scaler_SOURCES = media/video/test_video_scaler.cpp common.cpp
- check_PROGRAMS += ut_audio_frame_resizer
- ut_audio_frame_resizer_SOURCES = media/audio/test_audio_frame_resizer.cpp common.cpp
-
-+if ENABLE_INTEGRATION_TESTS
-+
-+#
-+# account_factory
-+#
-+check_PROGRAMS += ut_account_factory
-+ut_account_factory_SOURCES = account_factory/testAccount_factory.cpp common.cpp
-+
-+#
-+# account_archive
-+#
-+check_PROGRAMS += ut_account_archive
-+ut_account_archive_SOURCES = account_archive/account_archive.cpp common.cpp
-+
-+#
-+# migration
-+#
-+check_PROGRAMS += ut_migration
-+ut_migration_SOURCES = account_archive/migration.cpp common.cpp
-+
-+#
-+# certstore
-+#
-+check_PROGRAMS += ut_certstore
-+ut_certstore_SOURCES = certstore.cpp common.cpp
-+
- #
- # call
- #
-@@ -237,4 +239,6 @@ ut_sip_srtp_SOURCES = sip_account/sip_srtp.cpp
- check_PROGRAMS += ut_plugins
- ut_plugins_SOURCES = plugins/plugins.cpp common.cpp
-
-+endif # ENABLE_INTEGRATION_TESTS
-+
- TESTS = $(check_PROGRAMS)
---
-2.37.3
-