summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-04-01 13:27:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-06-26 11:01:02 +0300
commitaaf682222b36d6268e1325df6f1da33abba083f2 (patch)
tree7c022c205029da8efe0087bffa65edd57e4d0d48 /gnu
parent145d2ed168a8db0d667e9f32cdf93af06cba726a (diff)
gnu: Add rust-redox-syscall-0.5.
* gnu/packages/crates-io.scm (rust-redox-syscall-0.5): New variable. (rust-redox-syscall-0.4): Inherit from rust-redox-syscall-0.5. Change-Id: I8a67a8ad9740cde210eb3a39e31f0986cfdc38ba
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 23 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d9674fa276..94f36ad714 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -60944,22 +60944,22 @@ using tokio's @code{RwLock}")
owned memory.")
(license license:expat)))
-(define-public rust-redox-syscall-0.4
+(define-public rust-redox-syscall-0.5
(package
(name "rust-redox-syscall")
- (version "0.4.1")
+ (version "0.5.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "redox_syscall" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1aiifyz5dnybfvkk4cdab9p2kmphag1yad6iknc7aszlxxldf8j7"))))
+ (base32 "0zja6y3av9z50gg1hh0vsc053941wng21r43whhk8mfb9n4m5426"))))
(build-system cargo-build-system)
(arguments
- `(#:tests? #f ; could not find `CloneFlags` in the crate root
+ `(#:tests? #f ; Functions not implemented on Linux.
#:cargo-inputs
- (("rust-bitflags" ,rust-bitflags-1)
+ (("rust-bitflags" ,rust-bitflags-2)
("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1))))
(home-page "https://gitlab.redox-os.org/redox-os/syscall")
(synopsis "Rust library to access raw Redox system calls")
@@ -60967,6 +60967,24 @@ owned memory.")
"This package provides a Rust library to access raw Redox system calls.")
(license license:expat)))
+(define-public rust-redox-syscall-0.4
+ (package
+ (inherit rust-redox-syscall-0.5)
+ (name "rust-redox-syscall")
+ (version "0.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "redox_syscall" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1aiifyz5dnybfvkk4cdab9p2kmphag1yad6iknc7aszlxxldf8j7"))))
+ (arguments
+ `(#:tests? #f ; could not find `CloneFlags` in the crate root
+ #:cargo-inputs
+ (("rust-bitflags" ,rust-bitflags-1)
+ ("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1))))))
+
(define-public rust-redox-syscall-0.3
(package
(inherit rust-redox-syscall-0.4)