summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-04-10 21:22:42 -0700
committerLeo Famulari <leo@famulari.name>2020-05-29 10:44:34 -0400
commitb7250901f6e0143a6838d924742397986c1764b0 (patch)
treeb732265ce5ca9704a52423e6c7966d36f8307f2d /gnu
parent23e4b264d7ce196f660c5a92cc0a83c73b5e8b8e (diff)
gnu: Add ghc-atomic-write-0.2.0.7.
* gnu/packages/haskell-xyz.scm (ghc-atomic-write-0.2.0.7): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 8e18644f51..64c09c9274 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -567,6 +567,21 @@ will destroy the permissions on the original file. This library preserves
permissions while atomically writing to a file.")
(license license:expat)))
+(define-public ghc-atomic-write-0.2.0.7
+ (package
+ (inherit ghc-atomic-write)
+ (version "0.2.0.7")
+ (source
+ (origin
+ (inherit (package-source ghc-atomic-write))
+ (uri (string-append
+ "https://hackage.haskell.org/package/atomic-write/atomic-write-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "03cn3ii74h0w3g4h78xsx9v2sn58r3qsr2dbdwq340xwhiwcgxdm"))))))
+
(define-public ghc-attoparsec
(package
(name "ghc-attoparsec")