summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-25 00:22:59 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-25 02:01:03 -0400
commitbb32e349e12c9281a61cc669a7ae5ed6fb524a66 (patch)
tree1d5d34d5d7b2e928ab7bb34cf2eaefb3a48e30eb /gnu
parent8d8e65998bbd067325c83103cf5c8715017bc024 (diff)
gnu: Add python-node-semver.
* gnu/packages/python-xyz.scm (python-node-semver): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 413aa7bc81..ef44b00836 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5675,6 +5675,26 @@ includes the following improvements compared to @code{pdb}:
flexible plugin systems in Python.")
(license license:bsd-3)))
+(define-public python-node-semver
+ (package
+ (name "python-node-semver")
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "node-semver" version))
+ (sha256
+ (base32
+ "000ypfns5x72b41w5f9pk6k3jnr35scliqfbvmilyvv0178005i8"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/podhmo/python-node-semver")
+ (synopsis "Python port of node-semver")
+ (description "This module provides a Python version of node-semver, a
+semantic version parser for Node.js.")
+ (license license:expat)))
+
(define-public python-pyparsing
(package
(name "python-pyparsing")