summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-21 20:27:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-21 20:27:50 +0200
commitc8d8a9ec2f9fde37b24f8577f9753bf7d5605b58 (patch)
treed03e7bf3b9b0dc597929f9de8415bfb9314c127e /gnu
parent1e67f3650f3db5bb438d7ddcb2d86be06570092d (diff)
gnu: Add rust-hyper-rustls-0.26.
* gnu/packages/crates-web.scm (rust-hyper-rustls-0.26): New variable. (rust-hyper-rustls-0.24): Inherit from above. Change-Id: Ida566b09f96c9ee5602ba98181909c9facc256fb
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-web.scm50
1 files changed, 42 insertions, 8 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index c526f2f74e..0166e7ef0f 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -3738,8 +3738,48 @@ dependencies.")
(description "Proxy connector for the Hyper HTTP library.")
(license license:expat)))
+(define-public rust-hyper-rustls-0.26
+ (package
+ (name "rust-hyper-rustls")
+ (version "0.26.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "hyper-rustls" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0b4m1jvs147hxi8677n2dxxib663s7c31xmfni7b5qkanihsggm0"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ;not all files included
+ #:cargo-inputs
+ (("rust-futures-util" ,rust-futures-util-0.3)
+ ("rust-http" ,rust-http-1)
+ ("rust-hyper" ,rust-hyper-1)
+ ("rust-hyper-util" ,rust-hyper-util-0.1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-rustls" ,rust-rustls-0.22)
+ ("rust-rustls-native-certs" ,rust-rustls-native-certs-0.7)
+ ("rust-rustls-pki-types" ,rust-rustls-pki-types-1)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-tokio-rustls" ,rust-tokio-rustls-0.25)
+ ("rust-tower-service" ,rust-tower-service-0.3)
+ ("rust-webpki-roots" ,rust-webpki-roots-0.26))
+ #:cargo-development-inputs
+ (("rust-http-body-util" ,rust-http-body-util-0.1)
+ ("rust-hyper-util" ,rust-hyper-util-0.1)
+ ("rust-rustls" ,rust-rustls-0.22)
+ ("rust-rustls-pemfile" ,rust-rustls-pemfile-2)
+ ("rust-tokio" ,rust-tokio-1))))
+ (home-page "https://github.com/rustls/hyper-rustls")
+ (synopsis "Rustls+Hyper integration for pure Rust HTTPS")
+ (description
+ "This package provides Rustls+Hyper integration for pure Rust HTTPS.")
+ (license (list license:asl2.0 license:isc license:expat))))
+
(define-public rust-hyper-rustls-0.24
(package
+ (inherit rust-hyper-rustls-0.26)
(name "rust-hyper-rustls")
(version "0.24.2")
(source
@@ -3749,9 +3789,8 @@ dependencies.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1475j4a2nczz4aajzzsq3hpwg1zacmzbqg393a14j80ff8izsgpc"))))
- (build-system cargo-build-system)
(arguments
- `(#:tests? #f ; Not all files included.
+ `(#:tests? #f ; Not all files included.
#:cargo-inputs (("rust-futures-util" ,rust-futures-util-0.3)
("rust-http" ,rust-http-0.2)
("rust-hyper" ,rust-hyper-0.14)
@@ -3764,12 +3803,7 @@ dependencies.")
#:cargo-development-inputs (("rust-hyper" ,rust-hyper-0.14)
("rust-rustls" ,rust-rustls-0.21)
("rust-rustls-pemfile" ,rust-rustls-pemfile-1)
- ("rust-tokio" ,rust-tokio-1))))
- (home-page "https://github.com/rustls/hyper-rustls")
- (synopsis "Rustls+Hyper integration for pure Rust HTTPS")
- (description
- "This package provides Rustls+Hyper integration for pure Rust HTTPS.")
- (license (list license:asl2.0 license:isc license:expat))))
+ ("rust-tokio" ,rust-tokio-1))))))
(define-public rust-hyper-rustls-0.23
(package