summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-26 11:29:13 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-26 11:44:45 +0200
commitcc79cacceec45f4d731ca95eb9fc8006ce7e7cbc (patch)
tree8ee9bff0786bb7ca1ef272c444ef387d331f6a01 /gnu
parent358428c1ec5dfe1bd0e5d27eee66d251d4e5124f (diff)
gnu: python-jupyter-client-bootstrap: Hide zmq deprecation warning.
* gnu/packages/python-xyz.scm (python-jupyter-client-bootstrap)[arguments]: Add phase 'hide-zmq-deprecation-warning.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8ceabfb7ad..44834dc2f0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9589,6 +9589,14 @@ without using the configuration machinery.")
#:tests? #f
#:phases
#~(modify-phases %standard-phases
+ ;; The deprecation warnings break the tests.
+ (add-after 'unpack 'hide-zmq-deprecation-warnings
+ (lambda _
+ (substitute* "pyproject.toml"
+ (("\"ignore:There is no current event loop:DeprecationWarning:zmq\"," m)
+ (string-append m "
+\"ignore:zmq.eventloop.ioloop.*:DeprecationWarning\",
+\"ignore:zmq.tests.BaseZMQTestCase.*:DeprecationWarning\"")))))
(add-after 'unpack 'set-tool-file-names
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "jupyter_client/localinterfaces.py"