summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-01-28 09:45:22 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:47 +0200
commitfa9e3324b473b1051dfc4991f311b6e67b82c0fa (patch)
tree2a226a0a56bc313c1e76fe015b3ae7f7593ab252 /gnu
parenta4859a064c64dd67a241be4fc9522d90bd5cc855 (diff)
gnu: Add rust-arrow-row-47.
* gnu/packages/crates-io.scm (rust-arrow-row-47): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9ea60aa160..401ea5e38c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2842,6 +2842,39 @@ Arrow arrays. Examples include @code{cmp}, @code{ord}, @code{partition},
@code{rank} and @code{sort} kernels.")
(license license:asl2.0)))
+(define-public rust-arrow-row-47
+ (package
+ (name "rust-arrow-row")
+ (version "47.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "arrow-row" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "08jxyqvsm3pvz09jprqrxdhg1yczncyb5jlgj2vckrw1nn538jhi"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-ahash" ,rust-ahash-0.8)
+ ("rust-arrow-array" ,rust-arrow-array-47)
+ ("rust-arrow-buffer" ,rust-arrow-buffer-47)
+ ("rust-arrow-data" ,rust-arrow-data-47)
+ ("rust-arrow-schema" ,rust-arrow-schema-47)
+ ("rust-half" ,rust-half-2)
+ ("rust-hashbrown" ,rust-hashbrown-0.14))
+ #:cargo-development-inputs
+ (("rust-arrow-cast" ,rust-arrow-cast-47)
+ ("rust-arrow-ord" ,rust-arrow-ord-47)
+ ("rust-rand" ,rust-rand-0.8))))
+ (home-page "https://github.com/apache/arrow-rs")
+ (synopsis "Row-oriented Apache Arrow representation")
+ (description "This crate provides a comparable row-oriented representation
+of a collection of @code{Array}. Rows are normalized for sorting, and can
+therefore be very efficiently compared, using @code{memcmp} under the hood, or
+used in non-comparison sorts such as radix sort.")
+ (license license:asl2.0)))
+
(define-public rust-arrow-schema-47
(package
(name "rust-arrow-schema")