summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-11 23:06:06 +0200
committerLudovic Courtès <ludo@gnu.org>2015-06-11 23:33:32 +0200
commit0004c5904c2e69a89005eac8b6322d18a8e9f611 (patch)
tree11f626d46d7576cb29464791edf14b8a6a87df95 /gnu
parent8a16d064fa265c449d136ff6c3d3267e314cde8d (diff)
packages: Make 'location' field innate.
* guix/packages.scm (<package>)[location]: Add 'innate' property. * guix/build-system/gnu.scm (static-package): Remove 'loc' parameter and 'location' field. * gnu/packages/autotools.scm (autoconf-wrapper): Remove 'location' field. * gnu/packages/commencement.scm (gnu-make-boot0, diffutils-boot0, gcc-final): Likewise. * gnu/packages/cross-base.scm (cross): Likewise. * gnu/packages/emacs.scm (emacs-no-x, emacs-no-x-toolkit): Likewise. * gnu/packages/make-bootstrap.scm (tarball-package): Likewise. * gnu/packages/maths.scm (petsc-complex): Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/autotools.scm1
-rw-r--r--gnu/packages/commencement.scm3
-rw-r--r--gnu/packages/cross-base.scm1
-rw-r--r--gnu/packages/emacs.scm2
-rw-r--r--gnu/packages/make-bootstrap.scm3
-rw-r--r--gnu/packages/maths.scm1
6 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 24ff90cc5c..f2b4d95b95 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -95,7 +95,6 @@ use our own Bash instead of /bin/sh in shebangs. For that reason, it should
only be used internally---users should not end up distributing `configure'
files with a system-specific shebang."
(package (inherit autoconf)
- (location (source-properties->location (current-source-location)))
(name (string-append (package-name autoconf) "-wrapper"))
(build-system trivial-build-system)
(inputs `(("guile"
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 9611ff2620..a5402f0556 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -65,7 +65,6 @@
(package-with-bootstrap-guile
(package (inherit gnu-make)
(name "make-boot0")
- (location (source-properties->location (current-source-location)))
(arguments
`(#:guile ,%bootstrap-guile
#:implicit-inputs? #f
@@ -93,7 +92,6 @@
,@%bootstrap-inputs)
#:guile %bootstrap-guile)))
(package (inherit p)
- (location (source-properties->location (current-source-location)))
(arguments `(#:tests? #f ; the test suite needs diffutils
,@(package-arguments p)))))))
@@ -531,7 +529,6 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
;; The final GCC.
(package (inherit gcc-boot0)
(name "gcc")
- (location (source-properties->location (current-source-location)))
(arguments
`(#:guile ,%bootstrap-guile
#:implicit-inputs? #f
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index 9a459400e8..f1aca505d8 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -38,7 +38,6 @@
(define (cross p target)
(package (inherit p)
- (location (source-properties->location (current-source-location)))
(name (string-append (package-name p) "-cross-" target))
(arguments
(substitute-keyword-arguments (package-arguments p)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index fbddff1cf6..0f71c77bf2 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -123,7 +123,6 @@ languages.")
;; This is the version that you should use as an input to packages that just
;; need to byte-compile .el files.
(package (inherit emacs)
- (location (source-properties->location (current-source-location)))
(name "emacs-no-x")
(synopsis "The extensible, customizable, self-documenting text
editor (console only)")
@@ -138,7 +137,6 @@ editor (console only)")
(define-public emacs-no-x-toolkit
(package (inherit emacs)
- (location (source-properties->location (current-source-location)))
(name "emacs-no-x-toolkit")
(synopsis "The extensible, customizable, self-documenting text
editor (without an X toolkit)" )
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 88fad0e604..7f1b6d50b0 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -605,7 +605,6 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(define (tarball-package pkg)
"Return a package containing a tarball of PKG."
(package (inherit pkg)
- (location (source-properties->location (current-source-location)))
(name (string-append (package-name pkg) "-tarball"))
(build-system trivial-build-system)
(native-inputs `(("tar" ,tar)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4d837c85e2..6fbe6fd27d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -560,7 +560,6 @@ scientific applications modeled by partial differential equations.")
(define-public petsc-complex
(package (inherit petsc)
- (location (source-properties->location (current-source-location)))
(name "petsc-complex")
(arguments
(substitute-keyword-arguments (package-arguments petsc)