summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-02-07 22:55:45 +0100
committerLudovic Courtès <ludo@gnu.org>2016-02-07 23:46:01 +0100
commit48b311b1b3ba7d34b5d8825a23ea89e5091d2a95 (patch)
tree3509628756c6ea117d1a132dcd8768dd22068fd8 /gnu
parent7ec42f1d8a81908ca25cd8e7d14a60e719b63145 (diff)
gnu: python-cython: Define 'python2-variant'.
* gnu/packages/python.scm (python-cython)[properties]: New field. (python2-cython): Use 'strip-python2-variant'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b135ab7df1..702a333231 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
@@ -2940,10 +2940,12 @@ is designed to have a low barrier to entry.")
(description "Cython is an optimising static compiler for both the Python
programming language and the extended Cython programming language. It makes
writing C extensions for Python as easy as Python itself.")
- (license asl2.0)))
+ (license asl2.0)
+ (properties `((python2-variant . ,(delay python2-cython))))))
(define-public python2-cython
- (package (inherit (package-with-python2 python-cython))
+ (package (inherit (package-with-python2
+ (strip-python2-variant python-cython)))
(name "python2-cython")
(inputs
`(("python-2" ,python-2))))) ; this is not automatically changed