summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-29 21:08:30 -0400
committerLeo Famulari <leo@famulari.name>2016-10-29 21:43:24 -0400
commitbae187105907a1fe94fb2f6a661920299b9cd877 (patch)
treea26b5a45a7fceb8a396e1b407ae7db8865282d37 /gnu
parent10797a0ae0b57502ca3c4c8d98c6f0e062aacf8f (diff)
gnu: python-prompt-toolkit: Disable the test suite.
The tests were silently skipped with Python 3.4. With Python 3.5, this caused the build of python-prompt-toolkit to fail. * gnu/packages/python.scm (python-prompt-toolkit, python2-prompt-toolkit)[arguments]: Disable the tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a25d3bca4c..55efd4d4c0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10151,6 +10151,8 @@ implementation for Python.")
(base32
"1vyjd0b7wciv55i19l44zy0adx8q7ss79lhy2r9d1rwz2y4822zg"))))
(build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; The test suite uses some Windows-specific data types.
(inputs `(("python-wcwidth" ,python-wcwidth)
("python-pygments" ,python-pygments)))
(native-inputs `(("python-six" ,python-six)))