summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaoul Bonnal <ilpuccio.febo@gmail.com>2016-12-17 23:17:34 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-12-17 23:26:35 +1000
commitc9e9154e993f055a438e2e43518bbd0740aaaf24 (patch)
treec643d5c8d44f55955c90b26c513c7f32eaf4ed4f /gnu
parent51ad11ad6243cbde4c50c127cff2eec0abaf9ded (diff)
gnu: star: Update to 2.5.2b.
* gnu/packages/bioinformatics (star): Update to 2.5.2b. [source]: Delete precompiled binary. Co-authored-by: Ben Woodcroft <donttrustben@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3e9c82fbe3..9ce4e3a5ee 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4924,7 +4924,7 @@ application of SortMeRNA is filtering rRNA from metatranscriptomic data.")
(define-public star
(package
(name "star")
- (version "2.5.2a")
+ (version "2.5.2b")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/alexdobin/STAR/archive/"
@@ -4932,7 +4932,7 @@ application of SortMeRNA is filtering rRNA from metatranscriptomic data.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0xjlsm4p9flln111hv4xx7xy94c2nl53zvdvbk9winmiradjsdra"))
+ "1na6np880r1zaamiy00hy8bid5anpy0kgf63587v2yl080krk2zq"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -4941,6 +4941,7 @@ application of SortMeRNA is filtering rRNA from metatranscriptomic data.")
;; Remove pre-built binaries and bundled htslib sources.
(delete-file-recursively "bin/MacOSX_x86_64")
(delete-file-recursively "bin/Linux_x86_64")
+ (delete-file-recursively "bin/Linux_x86_64_static")
(delete-file-recursively "source/htslib")
#t))))
(build-system gnu-build-system)