summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-07-18 22:59:46 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-07-18 22:59:46 -0400
commit0e215f49fe359ca7e79993ade68c9b084c4161e9 (patch)
tree6d2ed3decb8667be7c0074560410de1a8a5b9d14 /gnu
parent82700f0fb357216527e6792f0d3d3842851fc167 (diff)
gnu: guile-opengl: Install compiled modules in the correct place.
* gnu/packages/gl.scm (guile-opengl): Install compiled modules in the same directory as the source modules.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gl.scm37
1 files changed, 21 insertions, 16 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index a6935d4189..e8003f88a3 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -409,22 +409,27 @@ extension functionality is exposed in a single header file.")
("glu" ,glu)
("freeglut" ,freeglut)))
(arguments
- '(#:phases (alist-cons-before
- 'build 'patch-dynamic-link
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (define (dynamic-link-substitute file lib input)
- (substitute* file
- (("dynamic-link \"lib([a-zA-Z]+)\"" _ lib)
- (string-append "dynamic-link \""
- (assoc-ref inputs input)
- "/lib/lib" lib "\""))))
- ;; Replace dynamic-link calls for libGL, libGLU, and
- ;; libglut with absolute paths to the store.
- (dynamic-link-substitute "glx/runtime.scm" "GL" "mesa")
- (dynamic-link-substitute "glu/runtime.scm" "GLU" "glu")
- (dynamic-link-substitute "glut/runtime.scm" "glut"
- "freeglut"))
- %standard-phases)))
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'configure 'patch-makefile
+ (lambda _
+ ;; Install compiled Guile files in the expected place.
+ (substitute* '("Makefile")
+ (("^godir = .*$")
+ "godir = $(moddir)\n"))))
+ (add-before 'build 'patch-dynamic-link
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (define (dynamic-link-substitute file lib input)
+ (substitute* file
+ (("dynamic-link \"lib([a-zA-Z]+)\"" _ lib)
+ (string-append "dynamic-link \""
+ (assoc-ref inputs input)
+ "/lib/lib" lib "\""))))
+ ;; Replace dynamic-link calls for libGL, libGLU, and
+ ;; libglut with absolute paths to the store.
+ (dynamic-link-substitute "glx/runtime.scm" "GL" "mesa")
+ (dynamic-link-substitute "glu/runtime.scm" "GLU" "glu")
+ (dynamic-link-substitute "glut/runtime.scm" "glut"
+ "freeglut"))))))
(home-page "http://gnu.org/s/guile-opengl")
(synopsis "Guile binding for the OpenGL graphics API")
(description