summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-19 21:11:56 -0400
committerMark H Weaver <mhw@netris.org>2015-07-19 23:20:39 -0400
commit629f4d2e6e04ce831a5b2c066d7a4d2d3281d3a7 (patch)
tree7b013c977eff48ae45fa0a2e6d912bfc1b0dbed9 /gnu
parente170571887dc072edae8b197527921c47743c62c (diff)
gnu: gcc-5.1, gcc-toolchain-5.1, libstdc++-doc-5.1: Rename to *-5.
This reflects the new version numbering scheme for GCC 5 and up. See <https://gcc.gnu.org/develop.html>. * gnu/packages/gcc.scm (gcc-5.1): Rename to ... (gcc-5): ... this. (libstdc++-doc-5.1): Rename to ... (libstdc++-doc-5): ... this, and use gcc-5. * gnu/packages/commencement.scm (gcc-toolchain-5.1): Rename to ... (gcc-toolchain-5): ... this, and use gcc-5. * build-aux/hydra/gnu-system.scm (%core-packages): Use gcc-5.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/commencement.scm4
-rw-r--r--gnu/packages/gcc.scm6
2 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index d3f239f5f7..74c3f304af 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -830,7 +830,7 @@ and binaries, plus debugging symbols in the 'debug' output), and Binutils.")
(define-public gcc-toolchain-4.9
(gcc-toolchain gcc-4.9))
-(define-public gcc-toolchain-5.1
- (gcc-toolchain gcc-5.1))
+(define-public gcc-toolchain-5
+ (gcc-toolchain gcc-5))
;;; commencement.scm ends here
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index d0a92786ff..6d6101b0fe 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -331,7 +331,7 @@ Go. It also includes runtime support libraries for these languages.")
"0zmnm00d2a1hsd41g34bhvxzvxisa2l584q3p447bd91lfjv4ci3"))
(patches (list (search-patch "gcc-libvtv-runpath.patch")))))))
-(define-public gcc-5.1
+(define-public gcc-5
(package (inherit gcc-4.9)
(version "5.1.0")
(source (origin
@@ -604,8 +604,8 @@ using compilers other than GCC."
(define-public libstdc++-doc-4.9
(make-libstdc++-doc gcc-4.9))
-(define-public libstdc++-doc-5.1
- (make-libstdc++-doc gcc-5.1))
+(define-public libstdc++-doc-5
+ (make-libstdc++-doc gcc-5))
(define-public isl
(package