summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-13 19:05:17 -0400
committerMark H Weaver <mhw@netris.org>2015-07-13 19:05:17 -0400
commit7a34576206620d61a58bca3fdcc46e1cc7669e22 (patch)
tree3ae9bba0ec856e58aa489aacca50ab608fff49fc /gnu
parent412a242258def6668a933efc56dd60bbd286d389 (diff)
gnu: corkscrew: Pass triplet instead of system as --build and --host.
This is a followup to commit 3c7d023d6458669c6bfa23bc85e098c91f699892, "build-system/gnu: Pass --build=<triplet> to configure by default" * gnu/packages/ssh.scm (corkscrew)[arguments]: In custom configure phase, accept 'build' keyword argument and pass it to configure in --build argument and, if not cross-compiling, the --host argument. Previously, the nix system string was passed.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ssh.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 0a1a841922..5d44b07f97 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -260,7 +260,7 @@ libssh library.")
'(#:phases
(alist-replace
'configure
- (lambda* (#:key outputs inputs system target
+ (lambda* (#:key outputs inputs system build target
#:allow-other-keys #:rest args)
(let* ((configure (assoc-ref %standard-phases 'configure))
(prefix (assoc-ref outputs "out"))
@@ -268,9 +268,8 @@ libssh library.")
;; Set --build and --host flags as the provided config.guess
;; is not able to detect them
(flags `(,(string-append "--prefix=" prefix)
- ,(string-append "--build=" system)
- ,(string-append "--host="
- (or target system)))))
+ ,(string-append "--build=" build)
+ ,(string-append "--host=" (or target build)))))
(setenv "CONFIG_SHELL" bash)
(zero? (apply system* bash
(string-append "." "/configure")