summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@openmailbox.org>2015-07-13 10:51:46 +0200
committerMathieu Lirzin <mthl@openmailbox.org>2015-07-16 11:56:04 +0200
commit7aab13f19d3aee27878cd67b41f5908b8e28767d (patch)
tree77db17edf0e1e1edae81a10839204b55cab06e83 /gnu
parent889e57f4d87696c32617bd5345d6ce28f3662c90 (diff)
gnu: Add gnome-common.
* gnu/packages/gnome.scm (gnome-common): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 879c27e86a..da8dd87f1c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
@@ -132,6 +133,28 @@ Desktop. It is designed to be as simple as possible and has some unique
features to enable users to create their discs easily and quickly.")
(license license:gpl2+)))
+(define-public gnome-common
+ (package
+ (name "gnome-common")
+ (version "3.14.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0b1676g4q44ah73c5gwl1kg88pc93pnq1pa9kwl43d0vg0pj802c"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.gnome.org/")
+ (synopsis "Bootstrap GNOME modules built from Git")
+ (description "gnome-common contains various files needed to bootstrap
+GNOME modules built from Git. It contains a common \"autogen.sh\" script that
+can be used to configure a source directory checked out from Git and some
+commonly used macros.")
+ (license license:gpl2+)))
+
(define-public gnome-desktop
(package
(name "gnome-desktop")