summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-07-14 16:15:30 +0200
committerLudovic Courtès <ludo@gnu.org>2015-07-14 16:15:30 +0200
commitc6d33a9d9c7a9ec3f5d7b1afb6d836dae3c8706e (patch)
tree3808675e61e513631fac582f01b024a75171f4c2 /gnu
parent7e5124976b0bc19cf26ef7376ea041b25b7fbd35 (diff)
gnu: Adjust packages to new handling of propagated inputs.
This is a followup to 161094c, which gets rid of the "a/b" notation for propagated inputs. * gnu/packages/cross-base.scm (cross-gcc-arguments): Change reference from "libc/linux-headers" to "linux-headers". * gnu/packages/emacs.scm (magit-svn): Change "magit/git-modes" to "git-modes".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cross-base.scm5
-rw-r--r--gnu/packages/emacs.scm3
2 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index b5e07b81f0..712aa9d585 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -165,8 +165,7 @@ may be either a libc package or #f.)"
;; Add the cross Linux headers to CROSS_CPATH, and remove them
;; from CPATH.
(let ((libc (assoc-ref inputs "libc"))
- (linux (assoc-ref inputs
- "libc/linux-headers")))
+ (linux (assoc-ref inputs "linux-headers")))
(define (cross? x)
;; Return #t if X is a cross-libc or cross Linux.
(or (string-prefix? libc x)
@@ -314,7 +313,7 @@ XBINUTILS and the cross tool chain."
#t))
,phases))))
- ;; Shadow the native "linux-headers" because glibc's recipe expect the
+ ;; Shadow the native "linux-headers" because glibc's recipe expects the
;; "linux-headers" input to point to the right thing.
(propagated-inputs `(("linux-headers" ,xlinux-headers)))
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index f00e15c86a..84e167d1fe 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -408,8 +408,7 @@ operations.")
"/bin/emacs"))
(magit (string-append (assoc-ref %build-inputs "magit")
"/share/emacs/site-lisp"))
- (commit (string-append (assoc-ref %build-inputs
- "magit/git-modes")
+ (commit (string-append (assoc-ref %build-inputs "git-modes")
"/share/emacs/site-lisp"))
(source (assoc-ref %build-inputs "source"))
(lisp-dir (string-append %output "/share/emacs/site-lisp")))