summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2019-07-24 20:21:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 23:05:39 +0200
commitad8f46c69efd24915d380dba663c9f24746de1fc (patch)
tree8e06839a9c1d4d31179021d97f8e1fe60710edfc /gnu
parent6deb08a35933714a1713406c2e81522bfb2c3401 (diff)
gnu: Add r-all.
* gnu/packages/bioconductor.scm (r-all): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index e5a2d66b2d..649b64a4d7 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -865,6 +865,34 @@ which were then sequenced to a depth of ~4 million reads per library,
resulting in a complete gene expression profile for each cell.")
(license license:artistic2.0)))
+(define-public r-all
+ (package
+ (name "r-all")
+ (version "1.26.0")
+ (source (origin
+ (method url-fetch)
+ ;; We cannot use bioconductor-uri here because this tarball is
+ ;; located under "data/experiment/" instead of "bioc/".
+ (uri (string-append "https://www.bioconductor.org/packages/"
+ "release/data/experiment/src/contrib/"
+ "ALL_" version ".tar.gz"))
+ (sha256
+ (base32
+ "1z7kpjw4ndj6fkxwvhqf3gawhrn26ksrlns7j2c78qzxqmjndik9"))))
+ (properties `((upstream-name . "ALL")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)))
+ (home-page "https://bioconductor.org/packages/ALL")
+ (synopsis "Acute Lymphoblastic Leukemia data from the Ritz laboratory")
+ (description
+ "The data consist of microarrays from 128 different individuals with
+@dfn{acute lymphoblastic leukemia} (ALL). A number of additional covariates
+are available. The data have been normalized (using rma) and it is the
+jointly normalized data that are available here. The data are presented in
+the form of an @code{exprSet} object.")
+ (license license:artistic2.0)))
+
;;; Packages