summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-02 15:07:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-09 17:07:28 +0200
commit05d28068ed6a54e87b2efdf357c045383875e135 (patch)
tree236e3816c8d2c7f3c2aad983b8cfd96a2dfe8b52 /gnu
parent702f23b3b85cd8a6aa11d3ebe1ad032faca3954b (diff)
gnu: texlive-latex-oberdiek: Build ifpdf package.
* gnu/packages/tex.scm (texlive-latex-oberdiek)[arguments]: Only build the "oberdiek.ins" package (which includes all other packages); patch file to build "ifpdf.dtx" instead of "ifpdf.ins".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e0584ebf17..0177fd2b67 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1022,13 +1022,14 @@ nameref packages, which make use of the facilities of hyperref.")
(build-system texlive-build-system)
(arguments
'(#:tex-directory "latex/oberdiek"
+ #:build-targets '("oberdiek.ins")
#:phases
(modify-phases %standard-phases
- ;; "ifpdf.ins" is not generated, so we cannot process it.
+ ;; "ifpdf.ins" is not generated, so we need to process the dtx file.
(add-after 'unpack 'do-not-process-ifpdf.ins
(lambda _
(substitute* "oberdiek.ins"
- (("\\\\batchinput\\{ifpdf.ins\\}") ""))
+ (("ifpdf.ins") "ifpdf.dtx"))
#t)))))
(home-page "http://www.ctan.org/pkg/oberdiek")
(synopsis "Bundle of packages submitted by Heiko Oberdiek")