summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-09 12:02:10 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-09 17:07:29 +0200
commit137f9cbc8880d9e54a0055fc7c6fe0c58a2124ea (patch)
tree62b41d19ffe9f6c32a7a41d82d1718da932ddcb6 /gnu
parent98b4aca156bff5ea1b522a8675ceba1a5c208ad1 (diff)
gnu: Add texlive-latex-amsfonts.
* gnu/packages/tex.scm (texlive-latex-amsfonts): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f7e6bb2686..aa4f739c55 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -719,6 +719,29 @@ Modern family of fonts. The Euler fonts are supported by separate packages;
details can be found in the documentation.")
(license license:silofl1.1)))
+(define-public texlive-latex-amsfonts
+ (package
+ (name "texlive-latex-amsfonts")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "amsfonts"))
+ (sha256
+ (base32
+ "0slzfv5h2m03b2xvm2sasznz4azh6rgi069z161dja3l8rln79hm"))))
+ (build-system texlive-build-system)
+ (arguments '(#:tex-directory "latex/amsfonts"))
+ (native-inputs
+ `(("texlive-fonts-cm" ,texlive-fonts-cm)
+ ("texlive-metafont-base" ,texlive-metafont-base)))
+ (home-page "http://www.ctan.org/pkg/amsfonts")
+ (synopsis "TeX fonts from the American Mathematical Society")
+ (description
+ "This package provides basic LaTeX support for the symbol fonts provides
+by the amsfonts package. It provides @code{amsfonts.sty}, with names of
+individual symbols defined in @code{amssymb.sty}.")
+ (license license:silofl1.1)))
+
;; This provides etex.src which is needed to build various formats, including
;; luatex.fmt and pdflatex.fmt
(define-public texlive-tex-plain