summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2020-06-27 15:07:01 +0200
committerLudovic Courtès <ludo@gnu.org>2020-07-13 12:52:52 +0200
commit13910d401285293ad6b6562bab43ec00de4f54b0 (patch)
tree7a6658b636e28d0bd7a428d4297b59da1ae3f007 /gnu
parentc5384ea3137243f77d901a51c45c5f489fa452f1 (diff)
gnu: Add python-pyopengl-accelerate.
* gnu/packages/python-xyz.scm (gnu/packages/python-xyz.scm): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f832793169..d49443e689 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15558,6 +15558,31 @@ related APIs. The binding is created using the standard @code{ctypes}
library.")
(license license:bsd-3)))
+(define-public python-pyopengl-accelerate
+ (package
+ (inherit python-pyopengl)
+ (name "python-pyopengl-accelerate")
+ (version "3.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyOpenGL-accelerate" version))
+ (sha256
+ (base32
+ "01iggy5jwxv7lxnj51zbmlbhag9wcb7dvrbwgi97i90n0a5m3r8j"))))
+ (inputs
+ `(("mesa" ,mesa)
+ ("python-numpy" ,python-numpy))) ; for cython module
+ ; numpy_formathandler, thus not propagated
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'fix-paths))))
+ (synopsis "Acceleration code for PyOpenGL")
+ (description
+ "This is the Cython-coded accelerator module for PyOpenGL.")))
+
(define-public python-rencode
(package
(name "python-rencode")