summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:40 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:16 -0700
commit16d4125e9070f7d4f44a78996a99735f6705a00c (patch)
tree775ea3597f15e15681c4912e216df9d9bb7cb507 /gnu
parent87129984cac8b47b5d1be8d1257998611e3e9244 (diff)
gnu: Add ghc-either.
* gnu/packages/haskell.scm (ghc-either): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index ac807bee2b..bb373e82cc 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9539,4 +9539,33 @@ statically known size.")
which consume random values.")
(license license:bsd-3)))
+(define-public ghc-either
+ (package
+ (name "ghc-either")
+ (version "4.4.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "either-" version "/"
+ "either-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1lrlwqqnm6ibfcydlv5qvvssw7bm0c6yypy0rayjzv1znq7wp1xh"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-bifunctors" ,ghc-bifunctors)
+ ("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-free" ,ghc-free)
+ ("ghc-monad-control" ,ghc-monad-control)
+ ("ghc-manodrandom" ,ghc-monadrandom)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-mmorph" ,ghc-mmorph)
+ ("ghc-profunctors" ,ghc-profunctors)
+ ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-semigroupoids" ,ghc-semigroupoids)
+ ("ghc-transformers-base" ,ghc-transformers-base)))
+ (home-page "https://github.com/ekmett/either")
+ (synopsis "Provides an either monad transformer for Haskell")
+ (description "This Haskell package provides an either monad transformer.")
+ (license license:bsd-3)))
;;; haskell.scm ends here