summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-05-20 18:29:43 +0200
committerLudovic Courtès <ludo@gnu.org>2013-05-20 18:29:43 +0200
commit1972fed4df6b733c77adbe00877f92bcf92bed02 (patch)
tree6c848e611511193f171738947057de992fbc7f65 /gnu
parent969e678ed9f907764e6412386432dfbddf493f71 (diff)
gnu: Add CVS.
* gnu/packages/version-control.scm (cvs): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm33
1 files changed, 31 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 74718f5149..6654be93b2 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -17,14 +17,16 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages version-control)
- #:use-module ((guix licenses) #:select (gpl2+ gpl3+))
+ #:use-module ((guix licenses) #:select (gpl1+ gpl2+ gpl3+))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (guix build utils)
#:use-module ((gnu packages gettext)
- #:renamer (symbol-prefix-proc 'guix:)))
+ #:renamer (symbol-prefix-proc 'guix:))
+ #:use-module (gnu packages nano)
+ #:use-module (gnu packages compression))
(define-public bazaar
(package
@@ -75,3 +77,30 @@ merging of revisions. RCS is useful for text that is revised frequently,
including source code, programs, documentation, graphics, papers, and form
letters.")
(license gpl3+)))
+
+(define-public cvs
+ (package
+ (name "cvs")
+ (version "1.12.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://ftp.gnu.org/non-gnu/cvs/source/feature/"
+ version "/cvs-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0pjir8cwn0087mxszzbsi1gyfc6373vif96cw4q3m1x6p49kd1bq"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; XXX: The test suite looks flawed, and the package is obsolete anyway.
+ '(#:tests? #f))
+ (inputs `(("zlib" ,zlib)
+ ("nano" ,nano))) ; the default editor
+ (home-page "http://cvs.nongnu.org")
+ (synopsis "Historical centralized version control system")
+ (description
+ "CVS is a version control system, an important component of Source
+Configuration Management (SCM). Using it, you can record the history of
+sources files, and documents. It fills a similar role to the free software
+RCS, PRCS, and Aegis packages.")
+ (license gpl1+)))