summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-26 19:47:28 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-26 20:54:53 +0200
commit296c84847f558c3a23c9e7cd4a4a0583676b0909 (patch)
tree3b860aff8ddae9a5c34d6d51f2e5a21e60e71111 /gnu
parentfc9c47bd7cdfd6265681e6b2c48fdb7889672bcc (diff)
gnu: stepmania: Fix build flags non-Intel machines.
* gnu/packages/games.scm (stepmania)[arguments]: Add a configure-flag on non-Intel machines to disable SSE2 optimizations.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6100ca79d7..5aa8fe6604 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -156,7 +156,9 @@
#:use-module (guix build-system scons)
#:use-module (guix build-system python)
#:use-module (guix build-system cmake)
- #:use-module (guix build-system trivial))
+ #:use-module (guix build-system trivial)
+ #:use-module ((srfi srfi-1) #:hide (zip))
+ #:use-module (srfi srfi-26))
(define-public armagetronad
(package
@@ -6045,6 +6047,12 @@ civilized than your own.")
#:out-of-source? #f ;for the 'install-desktop' phase
#:configure-flags
(list "-DWITH_SYSTEM_FFMPEG=1"
+ ;; SSE instructions are available on Intel systems only.
+ ,@(if (any (cute string-prefix? <> (or (%current-target-system)
+ (%current-system)))
+ '("x64_64" "i686"))
+ '()
+ '("-DWITH_SSE2=NO"))
;; Configuration cannot find GTK2 without the two following
;; flags.
(string-append "-DGTK2_GDKCONFIG_INCLUDE_DIR="