summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-02-15 00:26:52 +0100
committerLudovic Courtès <ludo@gnu.org>2013-02-27 20:55:39 +0100
commit2e48455d276501a27ddc6dada07407ce03256312 (patch)
tree9f0c1ad2e1e35be5396b915092541386f2c8a36a /gnu
parentf9c36483294f0e2eba9d0cde312023546aba9069 (diff)
gnu: linux-libre: Choose a config without debugging features.
* gnu/packages/linux.scm (linux-libre): Choose "defconfig" instead of "allmodconfig" since the latter enables all debugging features. Add `CONFIG_CIFS=m'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f3e7d18627..b97315580b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -133,7 +133,13 @@
(format #t "`ARCH' set to `~a'~%" (getenv "ARCH")))
(let ((build (assoc-ref %standard-phases 'build)))
- (and (zero? (system* "make" "allmodconfig"))
+ (and (zero? (system* "make" "defconfig"))
+ (begin
+ (format #t "enabling additional modules...~%")
+ (substitute* ".config"
+ (("^# CONFIG_CIFS.*$")
+ "CONFIG_CIFS=m\n"))
+ (zero? (system* "make" "oldconfig")))
;; Call the default `build' phase so `-j' is correctly
;; passed.