summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-03-30 09:19:24 +0100
committerAndreas Enge <andreas@enge.fr>2013-03-30 09:19:24 +0100
commit3a5d958570d9041d7eab509cbbc6e85956ad8858 (patch)
tree64d17fe30e0973221668563417791daafd84afdb /gnu
parent1f44111f8378fab19620a846e73592ac6861f572 (diff)
gnu: xorg: Fix compilation of xorg-server.
* gnu/packages/xorg.scm (mesa): Propagate input libxxf86vm.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm196
1 files changed, 98 insertions, 98 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index d83893213d..eb2b5e9a5c 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4343,71 +4343,6 @@ and Matrox.")
-;; package outside the x.org system proper of height 2
-
-(define-public mesa
- (package
- (name "mesa")
- ;; In newer versions (9.0.5 and 9.1 tested), "make" results in an
- ;; infinite configure loop, see
- ;; https://bugs.freedesktop.org/show_bug.cgi?id=61527
- (version "8.0.5")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "ftp://ftp.freedesktop.org/pub/mesa/" version
- "/MesaLib-" version
- ".tar.bz2"))
- (sha256
- (base32
- "0pjs8x51c0i6mawgd4w03lxpyx5fnx7rc8plr8jfsscf9yiqs6si"))))
- (build-system gnu-build-system)
- (propagated-inputs
- `(("glproto" ,glproto)
- ("libdrm" ,libdrm-2.4.33)
- ("libxdamage" ,libxdamage)))
- (inputs
- `(("bison" ,bison)
- ("dri2proto" ,dri2proto)
- ("expat" ,expat)
- ("flex" ,flex)
- ("libx11" ,libx11)
- ("libxext" ,libxext)
- ("libxfixes" ,libxfixes)
- ("libxml2" ,libxml2)
- ("libxxf86vm" ,libxxf86vm)
- ("makedepend" ,makedepend)
- ("pkg-config" ,pkg-config)
- ("python" ,python)))
- (arguments
- `(#:configure-flags
- `("--with-gallium-drivers=r600,svga,swrast") ; drop r300 from the default list as it requires llvm
- #:phases
- (alist-cons-after
- 'unpack 'remove-symlink
- (lambda* (#:key #:allow-other-keys)
- ;; remove dangling symlink to /usr/include/wine/windows
- (delete-file "src/gallium/state_trackers/d3d1x/w32api"))
- (alist-replace
- 'configure
- (lambda* (#:key inputs #:allow-other-keys #:rest args)
- (let ((configure (assoc-ref %standard-phases 'configure))
- (libxml2 (assoc-ref inputs "libxml2")))
- ;; FIXME: This should be done more centrally.
- (setenv "PYTHONPATH" (string-append libxml2 "/lib/python2.7/site-packages"))
- (apply configure args)))
- %standard-phases))))
- (home-page "http://mesa3d.org/")
- (synopsis "Mesa, an OpenGL implementation")
- (description "Mesa is a free implementation of the OpenGL specification -
-a system for rendering interactive 3D graphics. A variety of device drivers
-allows Mesa to be used in many different environments ranging from software
-emulation to complete hardware acceleration for modern GPUs.")
- (license license:x11)))
-
-
-
;; packages of height 2 in the propagated-inputs tree
(define-public libice
@@ -4639,6 +4574,104 @@ emulation to complete hardware acceleration for modern GPUs.")
(license license:x11)))
+;; package outside the x.org system proper of height 3
+
+(define-public mesa
+ (package
+ (name "mesa")
+ ;; In newer versions (9.0.5 and 9.1 tested), "make" results in an
+ ;; infinite configure loop, see
+ ;; https://bugs.freedesktop.org/show_bug.cgi?id=61527
+ (version "8.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "ftp://ftp.freedesktop.org/pub/mesa/" version
+ "/MesaLib-" version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "0pjs8x51c0i6mawgd4w03lxpyx5fnx7rc8plr8jfsscf9yiqs6si"))))
+ (build-system gnu-build-system)
+ (propagated-inputs
+ `(("glproto" ,glproto)
+ ("libdrm" ,libdrm-2.4.33)
+ ("libxdamage" ,libxdamage)
+ ("libxxf86vm" ,libxxf86vm)))
+ (inputs
+ `(("bison" ,bison)
+ ("dri2proto" ,dri2proto)
+ ("expat" ,expat)
+ ("flex" ,flex)
+ ("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("libxfixes" ,libxfixes)
+ ("libxml2" ,libxml2)
+ ("makedepend" ,makedepend)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (arguments
+ `(#:configure-flags
+ `("--with-gallium-drivers=r600,svga,swrast") ; drop r300 from the default list as it requires llvm
+ #:phases
+ (alist-cons-after
+ 'unpack 'remove-symlink
+ (lambda* (#:key #:allow-other-keys)
+ ;; remove dangling symlink to /usr/include/wine/windows
+ (delete-file "src/gallium/state_trackers/d3d1x/w32api"))
+ (alist-replace
+ 'configure
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (let ((configure (assoc-ref %standard-phases 'configure))
+ (libxml2 (assoc-ref inputs "libxml2")))
+ ;; FIXME: This should be done more centrally.
+ (setenv "PYTHONPATH" (string-append libxml2 "/lib/python2.7/site-packages"))
+ (apply configure args)))
+ %standard-phases))))
+ (home-page "http://mesa3d.org/")
+ (synopsis "Mesa, an OpenGL implementation")
+ (description "Mesa is a free implementation of the OpenGL specification -
+a system for rendering interactive 3D graphics. A variety of device drivers
+allows Mesa to be used in many different environments ranging from software
+emulation to complete hardware acceleration for modern GPUs.")
+ (license license:x11)))
+
+
+
+;; packages of height 3 in the propagated-inputs tree
+
+(define-public libxcb
+ (package
+ (name "libxcb")
+ (version "1.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://xcb.freedesktop.org/dist/libxcb-"
+ version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "03gspxcdl8r7jwbwg7fyp4cc6zic9z91amp4g5z0wwahx48nix6j"))))
+ (build-system gnu-build-system)
+ (propagated-inputs
+ `(("libpthread-stubs" ,libpthread-stubs)
+ ("libxau" ,libxau)
+ ("libxdmcp" ,libxdmcp)))
+ (inputs
+ `(("xcb-proto" ,xcb-proto)
+ ("libxslt" ,libxslt)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)
+ ("xproto" ,xproto)))
+ (home-page "http://www.x.org/wiki/")
+ (synopsis "xorg implementation of the X Window System")
+ (description "X.org provides an implementation of the X Window System")
+ (license license:x11)))
+
+
(define-public xorg-server
(package
(name "xorg-server")
@@ -4715,39 +4748,6 @@ emulation to complete hardware acceleration for modern GPUs.")
-;; packages of height 3 in the propagated-inputs tree
-
-(define-public libxcb
- (package
- (name "libxcb")
- (version "1.8.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "http://xcb.freedesktop.org/dist/libxcb-"
- version
- ".tar.bz2"))
- (sha256
- (base32
- "03gspxcdl8r7jwbwg7fyp4cc6zic9z91amp4g5z0wwahx48nix6j"))))
- (build-system gnu-build-system)
- (propagated-inputs
- `(("libpthread-stubs" ,libpthread-stubs)
- ("libxau" ,libxau)
- ("libxdmcp" ,libxdmcp)))
- (inputs
- `(("xcb-proto" ,xcb-proto)
- ("libxslt" ,libxslt)
- ("pkg-config" ,pkg-config)
- ("python" ,python)
- ("xproto" ,xproto)))
- (home-page "http://www.x.org/wiki/")
- (synopsis "xorg implementation of the X Window System")
- (description "X.org provides an implementation of the X Window System")
- (license license:x11)))
-
-
;; packages of height 4 in the propagated-inputs tree
(define-public libx11