summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:58 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:19 -0700
commit3a784700cd554c169d81b3013abb2a451f1e64b1 (patch)
treef8c2d828e0ece52ca1587b747dc5d75a681aacbf /gnu
parent95fb25bf5911cc324ba37098fe8bdbc94e7a3d74 (diff)
gnu: Add ghc-aws.
* gnu/packages/haskell.scm (ghc-aws): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a242d6be06..87e60a8861 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -10041,4 +10041,62 @@ unchunked data")
as well as a convenient Conduit module.")
(license license:expat)))
+(define-public ghc-aws
+ (package
+ (name "ghc-aws")
+ (version "0.17.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "aws-" version "/aws-" version ".tar.gz"))
+ (sha256 (base32
+ "1q4qh58vj8447a4fl88n3nkpdc4yv293qsh02w6zvszd6ch61yh7"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ; Tests require AWS credentials.
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-base16-bytestring" ,ghc-base16-bytestring)
+ ("ghc-base64-bytestring" ,ghc-base64-bytestring)
+ ("ghc-blaze-builder" ,ghc-blaze-builder)
+ ("ghc-byteable" ,ghc-byteable)
+ ("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-cereal" ,ghc-cereal)
+ ("ghc-conduit" ,ghc-conduit)
+ ("ghc-conduit-extra" ,ghc-conduit-extra)
+ ("ghc-cryptohash" ,ghc-cryptohash)
+ ("ghc-data-default" ,ghc-data-default)
+ ("ghc-http-conduit" ,ghc-http-conduit)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-monad-control" ,ghc-monad-control)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-network" ,ghc-network)
+ ("ghc-old-locale" ,ghc-old-locale)
+ ("ghc-safe" ,ghc-safe)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-tagged" ,ghc-tagged)
+ ("ghc-text" ,ghc-text)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-utf8-string" ,ghc-utf8-string)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-xml-conduit" ,ghc-xml-conduit)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-errors" ,ghc-errors)
+ ("ghc-http-client" ,ghc-http-client)
+ ("ghc-http-client-tls" ,ghc-http-client-tls)
+ ("ghc-quickcheck-instances" ,ghc-quickcheck-instances)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-conduit-combinators" ,ghc-conduit-combinators)))
+ (home-page "https://github.com/aristidb/aws")
+ (synopsis "Amazon Web Services for Haskell")
+ (description "This package attempts to provide support for using
+Amazon Web Services like S3 (storage), SQS (queuing) and others to
+Haskell programmers. The ultimate goal is to support all Amazon
+Web Services.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here