summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-03-10 13:00:57 +0100
committerAndreas Enge <andreas@enge.fr>2013-03-10 13:00:57 +0100
commit42ed9985b10c08dee53ca58b7d95b4608eb53161 (patch)
tree07059bacaeb46b8078852a03f8874c7b35dfac2e /gnu
parent2b8c5f547ac98b210d855e7ccb67e23cd344e3eb (diff)
gnu: xorg: Make xkeyboard-config compile.
* gnu/packages/xorg.scm (xkeyboard-config): Add inputs gettext, intltool, perl-xml-parser.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 2998b67c42..13c5c4d0c8 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -3663,9 +3663,24 @@ emulation to complete hardware acceleration for modern GPUs.")
"1nmb7ma8rqryicc5xqrn2hm5pwp5lkf7nj28bwbf63mz2r0mk892"))))
(build-system gnu-build-system)
(inputs
- `(("libx11" ,libx11)
+ `(("gettext" ,gnu:gettext)
+ ("intltool" ,intltool)
+ ("libx11" ,libx11)
+ ;; required to set PERL5LIB, although it is propagated by intltool
+ ("perl-xml-parser" ,perl-xml-parser)
("pkg-config" ,pkg-config)
("xkbcomp" ,xkbcomp)))
+ (arguments
+ `(#:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (let ((configure (assoc-ref %standard-phases 'configure))
+ (perl-xml-parser (assoc-ref inputs "perl-xml-parser")))
+ ;; FIXME: This should be done more centrally.
+ (setenv "PERL5LIB" (string-append perl-xml-parser "/lib/perl5/site_perl"))
+ (apply configure args)))
+ %standard-phases)))
(home-page "http://www.x.org/wiki/")
(synopsis "xorg implementation of the X Window System")
(description "X.org provides an implementation of the X Window System")