summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2019-08-03 13:24:50 +0100
committerLudovic Courtès <ludo@gnu.org>2019-08-22 17:59:31 +0200
commit46c1193a2914151bd594c79546b168c41cdb38d1 (patch)
tree2c164758b6df4099d1280aa7b4e6f01fd2599806 /gnu
parent5094da0b83a413778c2d364641c3972aae0a900f (diff)
gnu: Add emacs-mu4e-jump-to-list.
* gnu/packages/emacs-xyz.scm (emacs-mu4e-jump-to-list): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 06367aa991..eb9121fba3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -40,7 +40,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Alex Branham <alex.branham@gmail.com>
;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
-;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2018, 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2018, 2019 Brett Gilio <brettg@posteo.net>
;;; Copyright © 2019 Dimakakos Dimos <bendersteed@teknik.io>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
@@ -7305,6 +7305,34 @@ Additionally it can display the number of unread emails in the
mode-line.")
(license license:gpl3+)))
+(define-public emacs-mu4e-jump-to-list
+ (let ((commit "358bba003543b49ffa266e503e54aebd0ebe614b")
+ (revision "1"))
+ (package
+ (name "emacs-mu4e-jump-to-list")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/wavexx/mu4e-jump-to-list.el.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00y9nap61q1z2cdql4k9g7fgi2gdgd9iy5s5lzrd9a4agbx6r7sv"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("mu" ,mu)))
+ (home-page "https://gitlab.com/wavexx/mu4e-jump-to-list.el")
+ (synopsis "Select and view mailing lists in mu4e")
+ (description
+ "@code{mu4e-jump-to-list} allows you to select and view mailing lists
+automatically using existing List-ID headers in your mu database. Just press
+\"l\" in the headers view and any mailing list you've subscribed to will be
+automatically discovered and presented in recency order.")
+ (license license:gpl3+))))
+
(define-public emacs-pretty-mode
(package
(name "emacs-pretty-mode")