summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-21 03:14:52 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-04 17:54:39 +0100
commit5a4373572232a017a3579c164d37b981a370fc6f (patch)
tree3ec73ff8556368436fc814b1a79aa93fcf7b5ab7 /gnu
parent7fa9cca84afce09d3816b70ae6d42bfc08635e9d (diff)
gnu: snappy: Update to 1.1.7.
* gnu/packages/compression.scm (snappy): Update to 1.1.7. [source]: Change to git archive. Set file-name. [build-system]: Change to CMAKE-BUILD-SYSTEM. [arguments]: Add #:configure-flags. [description]: Fix infractions.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/compression.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 54c5928cb7..f55f0c2067 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1071,21 +1071,23 @@ algorithm within the Numpy framework.")
(define-public snappy
(package
(name "snappy")
- (version "1.1.3")
+ (version "1.1.7")
(source (origin
(method url-fetch)
- (uri (string-append
- "https://github.com/google/snappy/releases/download/"
- version "/" name "-" version ".tar.gz"))
+ (uri (string-append "https://github.com/google/snappy/archive/"
+ version ".tar.gz"))
+ (file-name (string-append "snappy-" version ".tar.gz"))
(sha256
(base32
- "1wzf8yif5ym2gj52db6v5m1pxnmn258i38x7llk9x346y2nq47ig"))))
- (build-system gnu-build-system)
+ "1m7rcdqzkys5lspj8jcsaah8w33zh28s771bw0ga2lgzfgl05yix"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
(home-page "https://github.com/google/snappy")
(synopsis "Fast compressor/decompressor")
- (description "Snappy is a compression/decompression library. It does not
+ (description "Snappy is a compression/decompression library. It does not
aim for maximum compression, or compatibility with any other compression library;
-instead, it aims for very high speeds and reasonable compression. For instance,
+instead, it aims for very high speeds and reasonable compression. For instance,
compared to the fastest mode of zlib, Snappy is an order of magnitude faster
for most inputs, but the resulting compressed files are anywhere from 20% to
100% bigger.")