summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-08-24 18:25:53 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-08-24 18:25:53 +0200
commit5c8b9a43819e174801597a249d4b46ab2526ca3b (patch)
tree174213bc0697cb167d72406003519ef32d270024 /gnu
parent9e4422d6831b2d71416028d09516d3ad97d65592 (diff)
gnu: sbcl: Enable core compression and xref for internals.
* gnu/packages/lisp.scm (sbcl): Do it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index a42369ba06..0c94283cc5 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -364,7 +364,8 @@ an interpreter, a compiler, a debugger, and much more.")
("inetutils" ,inetutils) ;for hostname(1)
("ed" ,ed)
("texlive" ,(texlive-union (list texlive-tex-texinfo)))
- ("texinfo" ,texinfo)))
+ ("texinfo" ,texinfo)
+ ("zlib" ,zlib)))
(arguments
`(#:modules ((guix build gnu-build-system)
(guix build utils)
@@ -422,6 +423,8 @@ an interpreter, a compiler, a debugger, and much more.")
;; them in HOME, so it needs to be writeable.
(add-before 'build 'set-HOME
(lambda _ (setenv "HOME" "/tmp") #t))
+ ;; TODO: We need to install the source as well (`src/code' directory)
+ ;; so that "go do definition" can work.
(replace 'build
(lambda* (#:key outputs #:allow-other-keys)
(setenv "CC" "gcc")
@@ -431,7 +434,9 @@ an interpreter, a compiler, a debugger, and much more.")
(_
`("clisp")))
(string-append "--prefix="
- (assoc-ref outputs "out")))))
+ (assoc-ref outputs "out"))
+ "--with-sb-core-compression"
+ "--with-sb-xref-for-internals")))
(replace 'install
(lambda _
(invoke "sh" "install.sh")))