summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-01-25 00:33:14 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-05-31 22:12:12 -0400
commit5ee8c1411dbbb752c1da1fcb4be4bf14dc87c72e (patch)
treef8d3e43cb64721bb2f28a242c774ee802ac96db0 /gnu
parent2f6d51ef9ae904aa857bed635750b857873408d1 (diff)
gnu: Add autotrace.
* gnu/packages/graphics.scm (autotrace): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphics.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 16ffda835e..b2bc63b9d0 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -43,6 +43,7 @@
#:use-module (gnu packages algebra)
#:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
@@ -52,6 +53,7 @@
#:use-module (gnu packages flex)
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
@@ -146,6 +148,61 @@ objects!")
(home-page "http://www.fox-toolkit.org")
(license license:lgpl2.1+)))
+(define-public autotrace
+ (let ((commit "travis-20190624.59")
+ (version-base "0.40.0"))
+ (package
+ (name "autotrace")
+ (version (string-append version-base "-"
+ (if (string-prefix? "travis-" commit)
+ (string-drop commit 7)
+ commit)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/autotrace/autotrace.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0mk4yavy42dj0pszr1ggnggpvmzs4ds46caa9wr55cqsypn7bq6s"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ ;; See: https://github.com/autotrace/autotrace/issues/27.
+ (add-after 'unpack 'include-spline.h-header
+ (lambda _
+ (substitute* "Makefile.am"
+ ((".*src/types.h.*" all)
+ (string-append all "\t\tsrc/spline.h \\\n")))
+ #t))
+ ;; See: https://github.com/autotrace/autotrace/issues/26.
+ (replace 'check
+ (lambda _
+ (invoke "sh" "tests/runtests.sh"))))))
+ (native-inputs
+ `(("which" ,which)
+ ("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("intltool" ,intltool)
+ ("libtool" ,libtool)
+ ("gettext" ,gettext-minimal)))
+ (inputs
+ `(("glib" ,glib)
+ ("libjpeg" ,libjpeg-turbo)
+ ("libpng" ,libpng)
+ ("imagemagick" ,imagemagick)
+ ("pstoedit" ,pstoedit)))
+ (home-page "https://github.com/autotrace/autotrace")
+ (synopsis "Bitmap to vector graphics converter")
+ (description "AutoTrace is a utility for converting bitmap into vector
+graphics. It can trace outlines and midlines, effect color reduction or
+despeckling and has support for many input and output formats. It can be used
+with the @command{autotrace} utility or as a C library, @code{libautotrace}.")
+ (license (list license:gpl2+ ;for the utility itself
+ license:lgpl2.1+))))) ;for use as a library
+
(define-public blender
(package
(name "blender")