summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-27 22:18:08 +0200
committerLudovic Courtès <ludo@gnu.org>2015-07-03 15:28:07 +0200
commit606c6380164224c3d18f91269d8ad2d95444f054 (patch)
tree9d20d29afb51a3b2df450b451dda94fe46e7cd64 /gnu
parent4b0f2ef743b47d8eab492151db3ae0541e808854 (diff)
gnu: gnutls: Move man3 pages to "doc" output.
* gnu/packages/gnutls.scm (gnutls)[arguments]: Add #:phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnutls.scm20
1 files changed, 18 insertions, 2 deletions
diff --git a/gnu/packages/gnutls.scm b/gnu/packages/gnutls.scm
index 4ed339a09b..415ea7a11e 100644
--- a/gnu/packages/gnutls.scm
+++ b/gnu/packages/gnutls.scm
@@ -135,8 +135,24 @@ living in the same process.")
;; FIXME: Temporarily disable p11-kit support since it is not
;; working on mips64el.
- "--without-p11-kit")))
- (outputs '("out" "debug"))
+ "--without-p11-kit")
+
+ #:phases (modify-phases %standard-phases
+ (add-after
+ 'install 'move-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Copy the 4.1 MiB of section 3 man pages to "doc".
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc"))
+ (mandir (string-append doc "/share/man"))
+ (oldman (string-append out "/share/man/man3")))
+ (mkdir-p mandir)
+ (copy-recursively oldman mandir)
+ (delete-file-recursively oldman)
+ #t))))))
+ (outputs '("out" ;4.4 MiB
+ "debug"
+ "doc")) ;4.1 MiB of man pages
(native-inputs
`(("pkg-config" ,pkg-config)
("which" ,which)))