summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorgabrielhdt <gabrielhondet@gmail.com>2019-05-11 22:11:40 +0200
committerLudovic Courtès <ludo@gnu.org>2019-05-12 23:52:17 +0200
commit62f6f3bb045cad63174a9706e182a06052f0b5b0 (patch)
treeee8b5beecdfebc42bb441b96ecf350eea3f2b54a /gnu
parent84c6639f414c8238d28ba9eb2b40809a808f48ad (diff)
gnu: Add emacs-ediprolog.
* gnu/packages/emacs-xyz.scm (emacs-ediprolog): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 069bf3e1f6..a4ac5c5b5f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -45,6 +45,7 @@
;;; Copyright © 2019 Dimakakos Dimos <bendersteed@teknik.io>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;; Copyright © 2019 mikadoZero <mikadozero@yandex.com>
+;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -15557,3 +15558,27 @@ between \"frame-width\" and \"frame-height\", between \"public\",
\"protected\" and \"private\" and between \"variable1\", \"variable2\" through
\"variableN\".")
(license license:gpl2+)))
+
+(define-public emacs-ediprolog
+ (package
+ (name "emacs-ediprolog")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://elpa.gnu.org/packages/ediprolog-"
+ version
+ ".el"))
+ (sha256
+ (base32
+ "039ffvp7c810mjyargmgw1i87g0z8qs8qicq826sd9aiz9hprfaz"))))
+ (build-system emacs-build-system)
+ (home-page "http://elpa.gnu.org/packages/ediprolog.html")
+ (synopsis "Emacs Does Interactive Prolog")
+ (description "This package provides a major mode that let the user
+interact with SWI-Prolog in all buffers. For instance, one can consult Prolog
+programs and evaluate embedded queries. This mode is focused on the command
+@code{ediprolog-dwim} (Do What I Mean) which is supposed to, depending on the
+context, carry out the appropriate action.")
+ (license license:gpl3+)))