summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-06-03 08:22:15 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-06-04 15:41:58 +0200
commit635b3636e20701450ead8294b69ee646a5c2fe42 (patch)
treec985425c4279595cc58c7e087dd7ebac593218df /gnu
parentd270df8d627aba2e7de4ded1a212735196a5585c (diff)
gnu: Add python-apispec.
* gnu/packages/python.scm (python-apispec, python2-apispec): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7cbeeb6fe0..6930c8c19b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15219,3 +15219,34 @@ complex datatypes to and from native Python datatypes.")
(define-public python2-bottle
(package-with-python2 python-bottle))
+
+(define-public python-apispec
+ (package
+ (name "python-apispec")
+ (version "0.22.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "apispec" version))
+ (sha256
+ (base32
+ "0y3jxmgp2d24am3hxl40f5rw9abb0r8037sagax3dv64h4n1azwq"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pyyaml" ,python-pyyaml)))
+ (native-inputs
+ `(("python-pytest-3.0" ,python-pytest-3.0)
+ ("python-flask" ,python-flask)
+ ("python-marshmallow" ,python-marshmallow)
+ ("python-tornado" ,python-tornado)
+ ("python-bottle" ,python-bottle)
+ ("python-mock" ,python-mock)))
+ (home-page "https://github.com/marshmallow-code/apispec")
+ (synopsis "Swagger 2.0 API specification generator")
+ (description "@code{python-apispec} is a pluggable API specification
+generator. Currently supports the OpenAPI specification (f.k.a.
+Swagger 2.0).")
+ (license license:expat)))
+
+(define-public python2-apispec
+ (package-with-python2 python-apispec))