summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-04-07 14:28:57 +0200
committerLeo Famulari <leo@famulari.name>2016-05-01 13:45:57 -0400
commit63bcec71409d383a75f25a880a713140be9fe4ca (patch)
tree9db183149cfe329b8830536a315e9a6ca106d762 /gnu
parentd706d943359926ddd0950bbcfc71eb98f671ee1d (diff)
gnu: Add python2-shedskin.
* gnu/packages/python.scm (python2-shedskin): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm43
1 files changed, 42 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f367e1e605..7593fc71ac 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -37,7 +37,7 @@
(define-module (gnu packages python)
#:use-module ((guix licenses)
#:select (asl2.0 bsd-4 bsd-3 bsd-2 non-copyleft cc0 x11 x11-style
- gpl2 gpl2+ gpl3+ lgpl2.0+ lgpl2.1 lgpl2.1+ lgpl3+ agpl3+
+ gpl2 gpl2+ gpl3 gpl3+ lgpl2.0+ lgpl2.1 lgpl2.1+ lgpl3+ agpl3+
isc mpl2.0 psfl public-domain repoze unlicense x11-style
zpl2.1))
#:use-module ((guix licenses) #:select (expat zlib) #:prefix license:)
@@ -78,6 +78,8 @@
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages zip)
#:use-module (gnu packages tcl)
+ #:use-module (gnu packages bdw-gc)
+ #:use-module (gnu packages pcre)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -8704,3 +8706,42 @@ respectively.")
(define-public python2-cysignals
(package-with-python2 python-cysignals))
+(define-public python2-shedskin
+ (package
+ (name "python2-shedskin")
+ (version "0.9.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/shedskin/shedskin/"
+ "releases/download/v" version
+ "/shedskin-" version ".tgz"))
+ (sha256
+ (base32
+ "0nzwrzgw1ga8rw6f0ryq7zr9kkiavd1cqz5hzxkcbicl1dk7kz41"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'fix-resulting-include-libs
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libgc (assoc-ref inputs "libgc"))
+ (pcre (assoc-ref inputs "pcre")))
+ (substitute* "shedskin/makefile.py"
+ (("variable == 'CCFLAGS':[ ]*")
+ (string-append "variable == 'CCFLAGS':\n"
+ " line += ' -I " pcre "/include"
+ " -I " libgc "/include'"))
+ (("variable == 'LFLAGS':[ ]*")
+ (string-append "variable == 'LFLAGS':\n"
+ " line += ' -L" pcre "/lib"
+ " -L " libgc "/lib'")))
+ #t))))))
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)))
+ (inputs `(("pcre" ,pcre)
+ ("libgc" ,libgc)))
+ (home-page "https://shedskin.github.io/")
+ (synopsis "Experimental Python-2 to C++ Compiler")
+ (description (string-append "This is an experimental compiler for a subset of
+Python. It generates C++ code and a Makefile."))
+ (license (list gpl3 bsd-3 license:expat))))