summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-03-24 00:57:25 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-25 11:39:26 +0100
commit6cd504ce75750a711b44b70ae066656dd9a252c8 (patch)
tree92c2f353d010fe8c5d6a2ad43c65b4b5eabf742d /gnu
parentbb034ab0803fc2b15d8e893a3483f0fdead7b86a (diff)
gnu: Add emacs-company-cabal.
* gnu/packages/emacs-xyz.scm (emacs-company-cabal): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c2c489b217..df475eea1c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3311,6 +3311,32 @@ insertion mode. When enabled all keys are implicitly prefixed with
sgml/html integration, and indentation (working with sgml).")
(license license:gpl3+)))
+(define-public emacs-company-cabal
+ ;; The latest version is 0.3.0, but no release has been provided after 0.2.1.
+ (let ((commit "62112a7259e24bd6c08885629a185afe512b7d3d")
+ (revision "1"))
+ (package
+ (name "emacs-company-cabal")
+ (version (git-version "0.3.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/iquiw/company-cabal/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1gf45xwjzdm8i4q6c6khk4dbg1mmp2r0awz2sjr4dcr2dbd1n7mg"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-company" ,emacs-company)))
+ (home-page "https://github.com/iquiw/company-cabal/")
+ (synopsis "Company completion for Haskell Cabal files")
+ (description
+ "This package allows for completion of field names, section names,
+field values, and more within @code{haskell-cabal-mode}.")
+ (license license:gpl3+))))
+
(define-public emacs-rfcview
(package
(name "emacs-rfcview")