summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-02-21 19:50:10 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-02-24 21:29:27 +0100
commit6f38dce749eb2b0339d39875737cbbd3cd6ac66e (patch)
tree91a4ad9b21759cfa5cd9ae7827d758b011de0d30 /gnu
parent8ba06a38c153ea15b54d66f23ef3521e427ed3f9 (diff)
gnu: Add Capture::Tiny.
* gnu/packages/perl.scm (perl-capture-tiny): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 2b7ca61203..5e3cdcb060 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -209,6 +209,29 @@ but don't want to go all out and profile your code.")
"Benchmark-Timer-" version))
(license gpl2)))
+(define-public perl-capture-tiny
+ (package
+ (name "perl-capture-tiny")
+ (version "0.28")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DA/DAGOLDEN/Capture-Tiny-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "117gmwipql1y5xnw9jil3lhdsrf2wsm9wjdzqj66x971n3fwm573"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Capture-Tiny")
+ (synopsis "Capture STDOUT and STDERR from Perl, XS or external programs")
+ (description
+ "Capture::Tiny provides a simple, portable way to capture almost anything
+sent to STDOUT or STDERR, regardless of whether it comes from Perl, from XS
+code or from an external program. Optionally, output can be teed so that it
+is captured while being passed through to the original file handles.")
+ (license asl2.0)))
+
(define-public perl-exporter-lite
(package
(name "perl-exporter-lite")