summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-06-18 16:47:00 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-06-18 17:14:08 +0200
commit6f517910226f65bf17e22d7baca9347d475f7a9e (patch)
tree48d36d36ad10cb2f1e298b8dc4e8ac35ae265ffc /gnu
parent7432a419b8c1a7aa469a8714040108ea73e5a7f8 (diff)
gnu: sbcl-triva.trivial: Remove ASD component fix.
* gnu/packages/lisp-xyz.scm (sbcl-triva.trivial)[arguments]: Don't replace create-asd-file phase now that our build system supports component-less .asd files.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 8fde80d48f..0fcc5c005a 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6216,32 +6216,6 @@ with extensible optimizer interface.")))
(name "sbcl-trivia.trivial")
(inputs
`(("trivia.level2" ,sbcl-trivia.level2)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'create-asd-file
- (lambda* (#:key outputs inputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib/" (%lisp-type)))
- (level2 (assoc-ref inputs "trivia.level2")))
- (mkdir-p lib)
- (install-file "trivia.trivial.asd" lib)
- ;; XXX: This .asd does not have any component and the build
- ;; system fails to work in this case. We should update the
- ;; build system to handle component-less .asd.
- ;; TODO: How do we append to file in Guile? It seems that
- ;; (open-file ... "a") gets a "Permission denied".
- (substitute* (string-append lib "/trivia.trivial.asd")
- (("\"\\)")
- (string-append "\")
-
-(progn (asdf/source-registry:ensure-source-registry)
- (setf (gethash
- \"trivia.level2\"
- asdf/source-registry:*source-registry*)
- #p\""
- level2
- "/share/common-lisp/sbcl-bundle-systems/trivia.level2.asd\"))")))))))))
(description "Trivia is a pattern matching compiler that is compatible
with Optima, another pattern matching library for Common Lisp. It is meant to
be faster and more extensible than Optima.