summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2014-02-14 03:16:46 +0100
committerCyril Roelandt <tipecaml@gmail.com>2014-03-25 14:41:32 +0100
commit70318b46722d4c11375148636d3cbae1f01114f1 (patch)
tree807aba1461dc901a32426ebaccba6eaa03175615 /gnu
parentb10ab7230f80076212ccd454f3648dd6ee7993fb (diff)
gnu: Python: use /nix/.../sh instead of /bin/sh in the subprocess module
* gnu/packages/python.scm (python-2): patch Lib/subprocess.py to use /nix/.../sh.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 056956e856..2c6992692a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -139,7 +139,15 @@
(with-directory-excursion out
(for-each (cut augment-rpath <> lib)
(find-files "bin" ".*")))))
- %standard-phases)))
+ (alist-replace
+ 'configure
+ (lambda* (#:key outputs #:allow-other-keys #:rest args)
+ (let ((configure (assoc-ref %standard-phases 'configure)))
+ (substitute* "Lib/subprocess.py"
+ (("args = \\[\"/bin/sh")
+ (string-append "args = [\"" (which "sh"))))
+ (apply configure args)))
+ %standard-phases))))
(inputs
`(("bzip2" ,bzip2)
("gdbm" ,gdbm)