summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-25 14:04:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-25 14:04:19 +0100
commit72a216a9d048a2a1018877b7e0eadb75fb278cf1 (patch)
tree0442f59669c4d2fb50f2803b94625dd0c5bd52fe /gnu
parent0ef062b338962dbe9b3c28334643b2410fbfef78 (diff)
gnu: r-optparse: Move to (gnu packages cran).
* gnu/packages/bioinformatics.scm (r-optparse): Move from here... * gnu/packages/cran.scm (r-optparse): ...to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm23
-rw-r--r--gnu/packages/cran.scm22
2 files changed, 22 insertions, 23 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index dcee9438a9..c1d7f5d20e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7339,29 +7339,6 @@ functionality.")
checks on R packages that are to be submitted to the Bioconductor repository.")
(license license:artistic2.0)))
-(define-public r-optparse
- (package
- (name "r-optparse")
- (version "1.6.1")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "optparse" version))
- (sha256
- (base32
- "04vyb6dhcga30mvghsg1p052jmf69xqxkvh3hzqz7dscyppy76w1"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-getopt" ,r-getopt)))
- (home-page
- "https://github.com/trevorld/optparse")
- (synopsis "Command line option parser")
- (description
- "This package provides a command line parser inspired by Python's
-@code{optparse} library to be used with Rscript to write shebang scripts
-that accept short and long options.")
- (license license:gpl2+)))
-
(define-public r-s4vectors
(package
(name "r-s4vectors")
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 03aa2f59f5..8bf5404a0c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12693,3 +12693,25 @@ SELECT or UPDATE queries to an end-point.")
(description "This package provides output formats and utilities for
authoring books and technical documents with R Markdown.")
(license license:gpl3)))
+
+(define-public r-optparse
+ (package
+ (name "r-optparse")
+ (version "1.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "optparse" version))
+ (sha256
+ (base32
+ "04vyb6dhcga30mvghsg1p052jmf69xqxkvh3hzqz7dscyppy76w1"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-getopt" ,r-getopt)))
+ (home-page "https://github.com/trevorld/optparse")
+ (synopsis "Command line option parser")
+ (description
+ "This package provides a command line parser inspired by Python's
+@code{optparse} library to be used with Rscript to write shebang scripts
+that accept short and long options.")
+ (license license:gpl2+)))