summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-06-12 16:22:30 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-06-12 16:23:44 +0200
commit798b80cea2ebf4a2303cef94468803cd50a51f7d (patch)
tree4ab2d422c23269234c08cc9485ef363c3e3578a9 /gnu
parent136eeb0b49b18ba0a4aef39871b7d8779a42bd7b (diff)
gnu: Add r-txdb-hsapiens-ucsc-hg38-knowngene.
* gnu/packages/bioconductor.scm (r-txdb-hsapiens-ucsc-hg38-knowngene): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c77e78a0f2..e87907fac5 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -590,6 +590,35 @@ data. It is derived from the UCSC hg19 genome and based on the \"knownGene\"
track. The database is exposed as a @code{TxDb} object.")
(license license:artistic2.0)))
+(define-public r-txdb-hsapiens-ucsc-hg38-knowngene
+ (package
+ (name "r-txdb-hsapiens-ucsc-hg38-knowngene")
+ (version "3.4.6")
+ (source (origin
+ (method url-fetch)
+ ;; We cannot use bioconductor-uri here because this tarball is
+ ;; located under "data/annotation/" instead of "bioc/".
+ (uri (string-append "https://bioconductor.org/packages/"
+ "release/data/annotation/src/contrib"
+ "/TxDb.Hsapiens.UCSC.hg38.knownGene_"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "12j7rri9r129v9w1yiqadg952dx462dh092sxif3r5kk8l7bxkn9"))))
+ (properties
+ `((upstream-name . "TxDb.Hsapiens.UCSC.hg38.knownGene")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-genomicfeatures" ,r-genomicfeatures)))
+ (home-page
+ "https://bioconductor.org/packages/TxDb.Hsapiens.UCSC.hg38.knownGene/")
+ (synopsis "Annotation package for human genome in TxDb format")
+ (description
+ "This package provides an annotation database of Homo sapiens genome
+data. It is derived from the UCSC hg38 genome and based on the \"knownGene\"
+track. The database is exposed as a @code{TxDb} object.")
+ (license license:artistic2.0)))
+
(define-public r-txdb-mmusculus-ucsc-mm9-knowngene
(package
(name "r-txdb-mmusculus-ucsc-mm9-knowngene")